summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--include/clblast.h10
-rw-r--r--include/internal/routines/xherk.h47
-rw-r--r--src/clblast.cc47
-rw-r--r--src/routines/xherk.cc156
-rw-r--r--test/performance/routines/xherk.cc40
-rw-r--r--test/routines/xherk.h121
-rw-r--r--test/wrapper_clblas.h28
8 files changed, 449 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60060961..61af6b82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,7 +98,7 @@ set(SAMPLE_PROGRAMS sgemm)
set(ROUTINES
xaxpy
xgemv
- xgemm xsymm xsyrk xsyr2k xtrmm)
+ xgemm xsymm xsyrk xherk xsyr2k xtrmm)
# ==================================================================================================
diff --git a/include/clblast.h b/include/clblast.h
index 5da10810..d7c902d9 100644
--- a/include/clblast.h
+++ b/include/clblast.h
@@ -140,6 +140,16 @@ StatusCode Syrk(const Layout layout, const Triangle triangle, const Transpose a_
cl_mem c_buffer, const size_t c_offset, const size_t c_ld,
cl_command_queue* queue, cl_event* event);
+// Templated-precision rank-K update of a hermitian matrix: CHERK/ZHERK
+template <typename T>
+StatusCode Herk(const Layout layout, const Triangle triangle, const Transpose a_transpose,
+ const size_t n, const size_t k,
+ const T alpha,
+ const cl_mem a_buffer, const size_t a_offset, const size_t a_ld,
+ const T beta,
+ cl_mem c_buffer, const size_t c_offset, const size_t c_ld,
+ cl_command_queue* queue, cl_event* event);
+
// Templated-precision rank-2K update of a symmetric matrix: SSYR2K/DSYR2K/CSYR2K/ZSYR2K
template <typename T>
StatusCode Syr2k(const Layout layout, const Triangle triangle, const Transpose ab_transpose,
diff --git a/include/internal/routines/xherk.h b/include/internal/routines/xherk.h
new file mode 100644
index 00000000..9b361254
--- /dev/null
+++ b/include/internal/routines/xherk.h
@@ -0,0 +1,47 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xherk routine. The precision is implemented using the template argument
+// 'T', whereas the alpha/beta arguments are of type 'U'. The implementation is very similar to the
+// Xsyrk routine.
+//
+// =================================================================================================
+
+#ifndef CLBLAST_ROUTINES_XHERK_H_
+#define CLBLAST_ROUTINES_XHERK_H_
+
+#include "internal/routine.h"
+
+namespace clblast {
+// =================================================================================================
+
+// See comment at top of file for a description of the class
+template <typename T, typename U>
+class Xherk: public Routine {
+ public:
+ Xherk(CommandQueue &queue, Event &event);
+
+ // Templated-precision implementation of the routine
+ StatusCode DoHerk(const Layout layout, const Triangle triangle, const Transpose a_transpose,
+ const size_t n, const size_t k,
+ const U alpha,
+ const Buffer &a_buffer, const size_t a_offset, const size_t a_ld,
+ const U beta,
+ const Buffer &c_buffer, const size_t c_offset, const size_t c_ld);
+
+ private:
+ // Static variable to get the precision
+ const static Precision precision_;
+};
+
+// =================================================================================================
+} // namespace clblast
+
+// CLBLAST_ROUTINES_XHERK_H_
+#endif
diff --git a/src/clblast.cc b/src/clblast.cc
index 299d0a18..638bc944 100644
--- a/src/clblast.cc
+++ b/src/clblast.cc
@@ -27,6 +27,7 @@
#include "internal/routines/xgemm.h"
#include "internal/routines/xsymm.h"
#include "internal/routines/xsyrk.h"
+#include "internal/routines/xherk.h"
#include "internal/routines/xsyr2k.h"
#include "internal/routines/xtrmm.h"
@@ -302,6 +303,50 @@ template StatusCode Syrk<double2>(const Layout, const Triangle, const Transpose,
// =================================================================================================
+// HERK
+template <typename T>
+StatusCode Herk(const Layout layout, const Triangle triangle, const Transpose a_transpose,
+ const size_t n, const size_t k, const T alpha,
+ const cl_mem a_buffer, const size_t a_offset, const size_t a_ld, const T beta,
+ cl_mem c_buffer, const size_t c_offset, const size_t c_ld,
+ cl_command_queue* queue, cl_event* event) {
+ auto queue_cpp = CommandQueue(*queue);
+ auto event_cpp = Event(*event);
+ auto routine = Xherk<std::complex<T>,T>(queue_cpp, event_cpp);
+
+ // Loads the kernel source-code as an include (C++11 raw string literal)
+ std::string common_source1 =
+ #include "kernels/copy.opencl"
+ std::string common_source2 =
+ #include "kernels/pad.opencl"
+ std::string common_source3 =
+ #include "kernels/transpose.opencl"
+ std::string common_source4 =
+ #include "kernels/padtranspose.opencl"
+ std::string kernel_source =
+ #include "kernels/xgemm.opencl"
+ auto status = routine.SetUp(common_source1 + common_source2 + common_source3 + common_source4 +
+ kernel_source);
+ if (status != StatusCode::kSuccess) { return status; }
+
+ // Runs the routine
+ return routine.DoHerk(layout, triangle, a_transpose, n, k, alpha,
+ Buffer(a_buffer), a_offset, a_ld, beta,
+ Buffer(c_buffer), c_offset, c_ld);
+}
+template StatusCode Herk<float>(const Layout, const Triangle, const Transpose,
+ const size_t, const size_t, const float,
+ const cl_mem, const size_t, const size_t, const float,
+ cl_mem, const size_t, const size_t,
+ cl_command_queue*, cl_event*);
+template StatusCode Herk<double>(const Layout, const Triangle, const Transpose,
+ const size_t, const size_t, const double,
+ const cl_mem, const size_t, const size_t, const double,
+ cl_mem, const size_t, const size_t,
+ cl_command_queue*, cl_event*);
+
+// =================================================================================================
+
// SYR2K
template <typename T>
StatusCode Syr2k(const Layout layout, const Triangle triangle, const Transpose ab_transpose,
@@ -456,7 +501,7 @@ StatusCode Trsm(const Layout layout, const Side side, const Triangle triangle,
Buffer(a_buffer), a_offset, a_ld,
Buffer(b_buffer), b_offset, b_ld);
*/
- return StatusCode::kSuccess;
+ return StatusCode::kNotImplemented;
}
template StatusCode Trsm<float>(const Layout, const Side, const Triangle,
const Transpose, const Diagonal,
diff --git a/src/routines/xherk.cc b/src/routines/xherk.cc
new file mode 100644
index 00000000..6bc9cd6c
--- /dev/null
+++ b/src/routines/xherk.cc
@@ -0,0 +1,156 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xherk class (see the header for information about the class).
+//
+// =================================================================================================
+
+#include "internal/routines/xherk.h"
+
+#include <string>
+#include <vector>
+
+namespace clblast {
+// =================================================================================================
+
+// Specific implementations to get the memory-type based on a template argument
+template <> const Precision Xherk<float2,float>::precision_ = Precision::kComplexSingle;
+template <> const Precision Xherk<double2,double>::precision_ = Precision::kComplexDouble;
+
+// =================================================================================================
+
+// Constructor: forwards to base class constructor
+template <typename T, typename U>
+Xherk<T,U>::Xherk(CommandQueue &queue, Event &event):
+ Routine(queue, event, {"Copy", "Pad", "Transpose", "PadTranspose", "Xgemm"}, precision_) {
+}
+
+// =================================================================================================
+
+// The main routine
+template <typename T, typename U>
+StatusCode Xherk<T,U>::DoHerk(const Layout layout, const Triangle triangle, const Transpose a_transpose,
+ const size_t n, const size_t k,
+ const U alpha,
+ const Buffer &a_buffer, const size_t a_offset, const size_t a_ld,
+ const U beta,
+ const Buffer &c_buffer, const size_t c_offset, const size_t c_ld) {
+
+ // Makes sure all dimensions are larger than zero
+ if ((n == 0) || (k == 0) ) { return StatusCode::kInvalidDimension; }
+
+ // Determines whether to apply the conjugate transpose to matrix B (argument: no transpose) or
+ // to matrix A (argument: conjugate transpose)
+ auto a_conjugate = (a_transpose != Transpose::kNo);
+ auto b_conjugate = (a_transpose == Transpose::kNo);
+
+ // Computes whether or not the matrices are transposed in memory. This is based on their layout
+ // (row or column-major) and whether or not they are requested to be pre-transposed.
+ auto a_rotated = (layout == Layout::kColMajor && a_conjugate) ||
+ (layout == Layout::kRowMajor && !a_conjugate);
+ auto c_rotated = (layout == Layout::kRowMajor);
+
+ // Computes the first and second dimensions of the A matrix taking the layout into account
+ auto a_one = (a_rotated) ? k : n;
+ auto a_two = (a_rotated) ? n : k;
+
+ // Tests the two matrices (A, C) for validity, first from a perspective of the OpenCL buffers and
+ // their sizes, and then from a perspective of parameter values (e.g. n, k). Tests whether the
+ // OpenCL buffers are valid and non-zero and whether the OpenCL buffers have sufficient storage
+ // space. Also tests that the leading dimensions of:
+ // matrix A cannot be less than N when rotated, or less than K when not-rotated
+ // matrix C cannot be less than N
+ auto status = TestMatrixA(a_one, a_two, a_buffer, a_offset, a_ld, sizeof(T));
+ if (ErrorIn(status)) { return status; }
+ status = TestMatrixC(n, n, c_buffer, c_offset, c_ld, sizeof(T));
+ if (ErrorIn(status)) { return status; }
+
+ // Calculates the ceiled versions of n and k
+ auto n_ceiled = Ceil(n, db_["NWG"]);
+ auto k_ceiled = Ceil(k, db_["KWG"]);
+
+ // Decides which kernel to run: the upper-triangular or lower-triangular version
+ auto kernel_name = (triangle == Triangle::kUpper) ? "XgemmUpper" : "XgemmLower";
+
+ // Allocates space on the device for padded and/or transposed input and output matrices.
+ try {
+ auto temp_a = Buffer(context_, CL_MEM_READ_WRITE, k_ceiled*n_ceiled*sizeof(T));
+ auto temp_b = Buffer(context_, CL_MEM_READ_WRITE, k_ceiled*n_ceiled*sizeof(T));
+ auto temp_c = Buffer(context_, CL_MEM_READ_WRITE, n_ceiled*n_ceiled*sizeof(T));
+
+ // Loads the program from the database
+ auto& program = GetProgramFromCache();
+
+ // Runs the pre-processing kernel. This transposes the matrix A, but also pads zeros to
+ // fill it up until it reaches a certain multiple of size (kernel parameter dependent). It
+ // creates two copies:
+ status = PadCopyTransposeMatrix(a_one, a_two, a_ld, a_offset, a_buffer,
+ n_ceiled, k_ceiled, n_ceiled, 0, temp_a,
+ a_rotated, a_conjugate, true, false, false, false, program);
+ if (ErrorIn(status)) { return status; }
+ status = PadCopyTransposeMatrix(a_one, a_two, a_ld, a_offset, a_buffer,
+ n_ceiled, k_ceiled, n_ceiled, 0, temp_b,
+ a_rotated, b_conjugate, true, false, false, false, program);
+ if (ErrorIn(status)) { return status; }
+
+ // Furthermore, also creates a (possibly padded) copy of matrix C, since it is not allowed to
+ // modify the other triangle.
+ status = PadCopyTransposeMatrix(n, n, c_ld, c_offset, c_buffer,
+ n_ceiled, n_ceiled, n_ceiled, 0, temp_c,
+ c_rotated, false, true, false, false, false, program);
+ if (ErrorIn(status)) { return status; }
+
+ // Retrieves the XgemmUpper or XgemmLower kernel from the compiled binary
+ try {
+ auto kernel = Kernel(program, kernel_name);
+
+ // Sets the kernel arguments
+ auto complex_alpha = T{alpha, static_cast<U>(0.0)};
+ auto complex_beta = T{beta, static_cast<U>(0.0)};
+ kernel.SetArgument(0, static_cast<int>(n_ceiled));
+ kernel.SetArgument(1, static_cast<int>(k_ceiled));
+ kernel.SetArgument(2, complex_alpha);
+ kernel.SetArgument(3, complex_beta);
+ kernel.SetArgument(4, temp_a());
+ kernel.SetArgument(5, temp_b());
+ kernel.SetArgument(6, temp_c());
+
+ // Computes the global and local thread sizes
+ auto global = std::vector<size_t>{
+ (n_ceiled * db_["MDIMC"]) / db_["MWG"],
+ (n_ceiled * db_["NDIMC"]) / db_["NWG"]
+ };
+ auto local = std::vector<size_t>{db_["MDIMC"], db_["NDIMC"]};
+
+ // Launches the kernel
+ status = RunKernel(kernel, global, local);
+ if (ErrorIn(status)) { return status; }
+
+ // Runs the post-processing kernel
+ auto upper = (triangle == Triangle::kUpper);
+ auto lower = (triangle == Triangle::kLower);
+ status = PadCopyTransposeMatrix(n_ceiled, n_ceiled, n_ceiled, 0, temp_c,
+ n, n, c_ld, c_offset, c_buffer,
+ c_rotated, false, false, upper, lower, true, program);
+ if (ErrorIn(status)) { return status; }
+
+ // Successfully finished the computation
+ return StatusCode::kSuccess;
+ } catch (...) { return StatusCode::kInvalidKernel; }
+ } catch (...) { return StatusCode::kTempBufferAllocFailure; }
+}
+
+// =================================================================================================
+
+// Compiles the templated class
+template class Xherk<float2,float>;
+template class Xherk<double2,double>;
+
+// =================================================================================================
+} // namespace clblast
diff --git a/test/performance/routines/xherk.cc b/test/performance/routines/xherk.cc
new file mode 100644
index 00000000..ce18152e
--- /dev/null
+++ b/test/performance/routines/xherk.cc
@@ -0,0 +1,40 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xherk command-line interface performance tester.
+//
+// =================================================================================================
+
+#include "performance/client.h"
+#include "routines/xherk.h"
+
+// =================================================================================================
+
+// Shortcuts to the clblast namespace
+using float2 = clblast::float2;
+using double2 = clblast::double2;
+
+// Main function (not within the clblast namespace)
+int main(int argc, char *argv[]) {
+ switch(clblast::GetPrecision(argc, argv)) {
+ case clblast::Precision::kHalf:
+ throw std::runtime_error("Unsupported precision mode");
+ case clblast::Precision::kSingle:
+ throw std::runtime_error("Unsupported precision mode");
+ case clblast::Precision::kDouble:
+ throw std::runtime_error("Unsupported precision mode");
+ case clblast::Precision::kComplexSingle:
+ clblast::RunClient<clblast::TestXherk<float2,float>, float2, float>(argc, argv); break;
+ case clblast::Precision::kComplexDouble:
+ clblast::RunClient<clblast::TestXherk<double2,double>, double2, double>(argc, argv); break;
+ }
+ return 0;
+}
+
+// =================================================================================================
diff --git a/test/routines/xherk.h b/test/routines/xherk.h
new file mode 100644
index 00000000..780b9b52
--- /dev/null
+++ b/test/routines/xherk.h
@@ -0,0 +1,121 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements a class with static methods to describe the Xherk routine. Examples of
+// such 'descriptions' are how to calculate the size a of buffer or how to run the routine. These
+// static methods are used by the correctness tester and the performance tester.
+//
+// =================================================================================================
+
+#ifndef CLBLAST_TEST_ROUTINES_XHERK_H_
+#define CLBLAST_TEST_ROUTINES_XHERK_H_
+
+#include <vector>
+#include <string>
+
+#include "wrapper_clblas.h"
+
+namespace clblast {
+// =================================================================================================
+
+// See comment at top of file for a description of the class
+template <typename T, typename U>
+class TestXherk {
+ public:
+
+ // The list of arguments relevant for this routine
+ static std::vector<std::string> GetOptions() {
+ return {kArgN, kArgK,
+ kArgLayout, kArgTriangle, kArgATransp,
+ kArgALeadDim, kArgCLeadDim,
+ kArgAOffset, kArgCOffset,
+ kArgAlpha, kArgBeta};
+ }
+
+ // Describes how to obtain the sizes of the buffers
+ static size_t GetSizeA(const Arguments<U> &args) {
+ auto a_rotated = (args.layout == Layout::kColMajor && args.a_transpose != Transpose::kNo) ||
+ (args.layout == Layout::kRowMajor && args.a_transpose == Transpose::kNo);
+ auto a_two = (a_rotated) ? args.n : args.k;
+ return a_two * args.a_ld + args.a_offset;
+ }
+ static size_t GetSizeC(const Arguments<U> &args) {
+ return args.n * args.c_ld + args.c_offset;
+ }
+
+ // Describes how to set the sizes of all the buffers
+ static void SetSizes(Arguments<U> &args) {
+ args.a_size = GetSizeA(args);
+ args.c_size = GetSizeC(args);
+ }
+
+ // Describes what the default values of the leading dimensions of the matrices are
+ static size_t DefaultLDA(const Arguments<U> &args) { return args.k; }
+ static size_t DefaultLDB(const Arguments<U> &) { return 1; } // N/A for this routine
+ static size_t DefaultLDC(const Arguments<U> &args) { return args.n; }
+
+ // Describes how to run the CLBlast routine
+ static StatusCode RunRoutine(const Arguments<U> &args, const Buffers &buffers,
+ CommandQueue &queue) {
+ auto queue_plain = queue();
+ auto event = cl_event{};
+ auto status = Herk(args.layout, args.triangle, args.a_transpose,
+ args.n, args.k, args.alpha,
+ buffers.a_mat(), args.a_offset, args.a_ld, args.beta,
+ buffers.c_mat(), args.c_offset, args.c_ld,
+ &queue_plain, &event);
+ clWaitForEvents(1, &event);
+ return status;
+ }
+
+ // Describes how to run the clBLAS routine (for correctness/performance comparison)
+ static StatusCode RunReference(const Arguments<U> &args, const Buffers &buffers,
+ CommandQueue &queue) {
+ auto queue_plain = queue();
+ auto event = cl_event{};
+ auto status = clblasXherk(static_cast<clblasOrder>(args.layout),
+ static_cast<clblasUplo>(args.triangle),
+ static_cast<clblasTranspose>(args.a_transpose),
+ args.n, args.k, args.alpha,
+ buffers.a_mat(), args.a_offset, args.a_ld, args.beta,
+ buffers.c_mat(), args.c_offset, args.c_ld,
+ 1, &queue_plain, 0, nullptr, &event);
+ clWaitForEvents(1, &event);
+ return static_cast<StatusCode>(status);
+ }
+
+ // Describes how to download the results of the computation (more importantly: which buffer)
+ static std::vector<T> DownloadResult(const Arguments<U> &args, Buffers &buffers,
+ CommandQueue &queue) {
+ std::vector<T> result(args.c_size, static_cast<T>(0));
+ buffers.c_mat.ReadBuffer(queue, args.c_size*sizeof(T), result);
+ return result;
+ }
+
+ // Describes how to compute the indices of the result buffer
+ static size_t ResultID1(const Arguments<U> &args) { return args.n; }
+ static size_t ResultID2(const Arguments<U> &args) { return args.n; }
+ static size_t GetResultIndex(const Arguments<U> &args, const size_t id1, const size_t id2) {
+ return id1*args.c_ld + id2 + args.c_offset;
+ }
+
+ // Describes how to compute performance metrics
+ static size_t GetFlops(const Arguments<U> &args) {
+ return args.n * args.n * args.k;
+ }
+ static size_t GetBytes(const Arguments<U> &args) {
+ return (args.n*args.k + args.n*args.n) * sizeof(T);
+ }
+};
+
+// =================================================================================================
+} // namespace clblast
+
+// CLBLAST_TEST_ROUTINES_XHERK_H_
+#endif
diff --git a/test/wrapper_clblas.h b/test/wrapper_clblas.h
index a03ade5e..360adfc8 100644
--- a/test/wrapper_clblas.h
+++ b/test/wrapper_clblas.h
@@ -325,6 +325,34 @@ clblasStatus clblasXsyrk(
num_queues, queues, num_wait_events, wait_events, events);
}
+// This calls {clblasCherk, clblasZherk} with the arguments forwarded.
+clblasStatus clblasXherk(
+ clblasOrder layout, clblasUplo triangle, clblasTranspose a_transpose,
+ size_t n, size_t k, float alpha,
+ const cl_mem a_mat, size_t a_offset, size_t a_ld, float beta,
+ const cl_mem c_mat, size_t c_offset, size_t c_ld,
+ cl_uint num_queues, cl_command_queue *queues,
+ cl_uint num_wait_events, const cl_event *wait_events, cl_event *events) {
+ return clblasCherk(layout, triangle, a_transpose,
+ n, k, alpha,
+ a_mat, a_offset, a_ld, beta,
+ c_mat, c_offset, c_ld,
+ num_queues, queues, num_wait_events, wait_events, events);
+}
+clblasStatus clblasXherk(
+ clblasOrder layout, clblasUplo triangle, clblasTranspose a_transpose,
+ size_t n, size_t k, double alpha,
+ const cl_mem a_mat, size_t a_offset, size_t a_ld, double beta,
+ const cl_mem c_mat, size_t c_offset, size_t c_ld,
+ cl_uint num_queues, cl_command_queue *queues,
+ cl_uint num_wait_events, const cl_event *wait_events, cl_event *events) {
+ return clblasZherk(layout, triangle, a_transpose,
+ n, k, alpha,
+ a_mat, a_offset, a_ld, beta,
+ c_mat, c_offset, c_ld,
+ num_queues, queues, num_wait_events, wait_events, events);
+}
+
// This calls {clblasSsyr2k, clblasDsyr2k, clblasCsyr2k, clblasZsyr2k} with the arguments forwarded.
clblasStatus clblasXsyr2k(
clblasOrder layout, clblasUplo triangle, clblasTranspose ab_transpose,