summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xscripts/generator/generator.py2
-rw-r--r--src/pyclblast/MANIFEST.in2
-rw-r--r--src/pyclblast/README.md31
-rw-r--r--src/pyclblast/setup.py17
-rw-r--r--src/pyclblast/src/pyclblast.pyx (renamed from src/pyclblast/pyclblast/pyclblast.pyx)0
5 files changed, 47 insertions, 5 deletions
diff --git a/scripts/generator/generator.py b/scripts/generator/generator.py
index c25d0e4f..8c071ab3 100755
--- a/scripts/generator/generator.py
+++ b/scripts/generator/generator.py
@@ -47,7 +47,7 @@ FILES = [
"/src/clblast_netlib_c.cpp",
"/include/clblast_cuda.h",
"/src/clblast_cuda.cpp",
- "/src/pyclblast/pyclblast/pyclblast.pyx"
+ "/src/pyclblast/src/pyclblast.pyx"
]
HEADER_LINES = [123, 21, 126, 24, 29, 41, 29, 65, 32, 95, 21, 288]
FOOTER_LINES = [41, 56, 27, 38, 6, 6, 6, 9, 2, 41, 55, 1]
diff --git a/src/pyclblast/MANIFEST.in b/src/pyclblast/MANIFEST.in
new file mode 100644
index 00000000..fb20923f
--- /dev/null
+++ b/src/pyclblast/MANIFEST.in
@@ -0,0 +1,2 @@
+include README.md setup.py src/*.pyx
+include samples/*.py
diff --git a/src/pyclblast/README.md b/src/pyclblast/README.md
new file mode 100644
index 00000000..be37af01
--- /dev/null
+++ b/src/pyclblast/README.md
@@ -0,0 +1,31 @@
+
+PyCLBlast: Python wrappers for the tuned OpenCL BLAS library CLBlast
+================
+
+This Python package provides a straightforward wrapper for CLBast based on PyOpenCL. CLBlast is a modern, lightweight, performant and tunable OpenCL BLAS library written in C++11. It is designed to leverage the full performance potential of a wide variety of OpenCL devices from different vendors, including desktop and laptop GPUs, embedded GPUs, and other accelerators. CLBlast implements BLAS routines: basic linear algebra subprograms operating on vectors and matrices.
+
+See [the CLBlast repository](https://github.com/CNugteren/CLBlast) and [the CLBlast website](https://cnugteren.github.io/clblast) for more information about CLBlast.
+
+
+Prerequisites
+-------------
+
+Non-Python requirements:
+
+* OpenCL
+* [CLBlast](https://github.com/CNugteren/CLBlast)
+
+Python requirements:
+
+* Cython
+* [PyOpenCL](https://github.com/pyopencl/pyopencl/)
+
+
+Getting started
+-------------
+
+After installation OpenCL and CLBlast, simply use pip to install PyCLBlast, e.g.:
+
+ pip install --user pyclblast
+
+To start using the library, browse the [CLBlast](https://github.com/CNugteren/CLBlast) documentation or check out the PyCLBlast samples provides in the `samples` subfolder.
diff --git a/src/pyclblast/setup.py b/src/pyclblast/setup.py
index 2a90f16d..d5916e06 100644
--- a/src/pyclblast/setup.py
+++ b/src/pyclblast/setup.py
@@ -14,7 +14,7 @@ ext_modules = list()
ext_modules.append(
Extension(
"pyclblast",
- ["pyclblast/pyclblast.pyx"],
+ ["src/pyclblast.pyx"],
libraries=["clblast"],
language="c++"
)
@@ -27,10 +27,19 @@ setup(
author_email="web@cedricnugteren.nl",
url="https://github.com/cnugteren/clblast",
description="Python bindings for CLBlast, the tuned OpenCL BLAS library",
- license="ApacheV2",
- requires=["pyopencl","cython"],
- packages=["pyclblast"],
+ license="Apache Software License",
+ requires=["numpy", "pyopencl", "cython"],
+ package_dir={'': 'src'},
scripts=[],
ext_modules=ext_modules,
cmdclass={"build_ext": build_ext},
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Topic :: Software Development :: Libraries',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ ],
+ keywords="OpenCL BLAS CLBlast GEMM matrix-multiplication"
)
diff --git a/src/pyclblast/pyclblast/pyclblast.pyx b/src/pyclblast/src/pyclblast.pyx
index 9529400c..9529400c 100644
--- a/src/pyclblast/pyclblast/pyclblast.pyx
+++ b/src/pyclblast/src/pyclblast.pyx