summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--include/internal/routines/xtrmm.h58
-rw-r--r--src/clblast.cc4
-rw-r--r--src/kernels/pad.opencl97
-rw-r--r--src/routines/xtrmm.cc135
-rw-r--r--test/correctness/routines/xtrmm.cc96
-rw-r--r--test/performance/graphs/xtrmm.r127
-rw-r--r--test/performance/routines/xtrmm.cc36
-rw-r--r--test/routines/xtrmm.h127
9 files changed, 666 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60b1aaed..60060961 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,7 +98,7 @@ set(SAMPLE_PROGRAMS sgemm)
set(ROUTINES
xaxpy
xgemv
- xgemm xsymm xsyrk xsyr2k)
+ xgemm xsymm xsyrk xsyr2k xtrmm)
# ==================================================================================================
diff --git a/include/internal/routines/xtrmm.h b/include/internal/routines/xtrmm.h
new file mode 100644
index 00000000..af9f0266
--- /dev/null
+++ b/include/internal/routines/xtrmm.h
@@ -0,0 +1,58 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xtrmm routine. The implementation is based on first transforming the
+// upper/lower unit/non-unit triangular matrix into a regular matrix and then calling the GEMM
+// routine. Therefore, this class inherits from the Xgemm class.
+//
+// =================================================================================================
+
+#ifndef CLBLAST_ROUTINES_XTRMM_H_
+#define CLBLAST_ROUTINES_XTRMM_H_
+
+#include "internal/routines/xgemm.h"
+
+namespace clblast {
+// =================================================================================================
+
+// See comment at top of file for a description of the class
+template <typename T>
+class Xtrmm: public Xgemm<T> {
+ public:
+
+ // Uses several variables from the Routine class
+ using Routine::db_;
+ using Routine::context_;
+
+ // Uses several helper functions from the Routine class
+ using Routine::RunKernel;
+ using Routine::ErrorIn;
+ using Routine::TestMatrixA;
+ using Routine::GetProgramFromCache;
+
+ // Uses the regular Xgemm routine
+ using Xgemm<T>::DoGemm;
+
+ // Constructor
+ Xtrmm(CommandQueue &queue, Event &event);
+
+ // Templated-precision implementation of the routine
+ StatusCode DoTrmm(const Layout layout, const Side side, const Triangle triangle,
+ const Transpose a_transpose, const Diagonal diagonal,
+ const size_t m, const size_t n,
+ const T alpha,
+ const Buffer &a_buffer, const size_t a_offset, const size_t a_ld,
+ const Buffer &b_buffer, const size_t b_offset, const size_t b_ld);
+};
+
+// =================================================================================================
+} // namespace clblast
+
+// CLBLAST_ROUTINES_XTRMM_H_
+#endif
diff --git a/src/clblast.cc b/src/clblast.cc
index e3ce4d39..299d0a18 100644
--- a/src/clblast.cc
+++ b/src/clblast.cc
@@ -28,6 +28,7 @@
#include "internal/routines/xsymm.h"
#include "internal/routines/xsyrk.h"
#include "internal/routines/xsyr2k.h"
+#include "internal/routines/xtrmm.h"
namespace clblast {
// =================================================================================================
@@ -372,7 +373,6 @@ StatusCode Trmm(const Layout layout, const Side side, const Triangle triangle,
cl_command_queue* queue, cl_event* event) {
auto queue_cpp = CommandQueue(*queue);
auto event_cpp = Event(*event);
- /*
auto routine = Xtrmm<T>(queue_cpp, event_cpp);
// Loads the kernel source-code as an include (C++11 raw string literal)
@@ -394,8 +394,6 @@ StatusCode Trmm(const Layout layout, const Side side, const Triangle triangle,
return routine.DoTrmm(layout, side, triangle, a_transpose, diagonal, m, n, alpha,
Buffer(a_buffer), a_offset, a_ld,
Buffer(b_buffer), b_offset, b_ld);
- */
- return StatusCode::kSuccess;
}
template StatusCode Trmm<float>(const Layout, const Side, const Triangle,
const Transpose, const Diagonal,
diff --git a/src/kernels/pad.opencl b/src/kernels/pad.opencl
index cce0c746..8294fab7 100644
--- a/src/kernels/pad.opencl
+++ b/src/kernels/pad.opencl
@@ -135,15 +135,15 @@ __kernel void SymmLowerToSquared(const int src_dim,
if (id_two < dest_dim && id_one < dest_dim) {
// Loads data from the lower-symmetric matrix
- real value;
- SetToZero(value);
+ real result;
+ SetToZero(result);
if (id_two < src_dim && id_one < src_dim) {
- if (id_two <= id_one) { value = src[id_two*src_ld + id_one + src_offset]; }
- else { value = src[id_one*src_ld + id_two + src_offset]; }
+ if (id_two <= id_one) { result = src[id_two*src_ld + id_one + src_offset]; }
+ else { result = src[id_one*src_ld + id_two + src_offset]; }
}
- // Stores the value in the destination matrix
- dest[id_two*dest_ld + id_one + dest_offset] = value;
+ // Stores the result in the destination matrix
+ dest[id_two*dest_ld + id_one + dest_offset] = result;
}
}
}
@@ -168,15 +168,88 @@ __kernel void SymmUpperToSquared(const int src_dim,
if (id_two < dest_dim && id_one < dest_dim) {
// Loads data from the upper-symmetric matrix
- real value;
- SetToZero(value);
+ real result;
+ SetToZero(result);
if (id_two < src_dim && id_one < src_dim) {
- if (id_one <= id_two) { value = src[id_two*src_ld + id_one + src_offset]; }
- else { value = src[id_one*src_ld + id_two + src_offset]; }
+ if (id_one <= id_two) { result = src[id_two*src_ld + id_one + src_offset]; }
+ else { result = src[id_one*src_ld + id_two + src_offset]; }
}
- // Stores the value in the destination matrix
- dest[id_two*dest_ld + id_one + dest_offset] = value;
+ // Stores the result in the destination matrix
+ dest[id_two*dest_ld + id_one + dest_offset] = result;
+ }
+ }
+ }
+}
+
+// =================================================================================================
+
+// Kernel to populate a squared triangular matrix, given that the triangle which holds the data is
+// stored as the lower-triangle of the input matrix. This uses the padding kernel's parameters.
+__attribute__((reqd_work_group_size(PAD_DIMX, PAD_DIMY, 1)))
+__kernel void TrmmLowerToSquared(const int src_dim,
+ const int src_ld, const int src_offset,
+ __global const real* restrict src,
+ const int dest_dim,
+ const int dest_ld, const int dest_offset,
+ __global real* dest,
+ const int unit_diagonal) {
+
+ // Loops over the work per thread in both dimensions
+ #pragma unroll
+ for (int w_one=0; w_one<PAD_WPTX; ++w_one) {
+ const int id_one = (get_group_id(0)*PAD_WPTX + w_one) * PAD_DIMX + get_local_id(0);
+ #pragma unroll
+ for (int w_two=0; w_two<PAD_WPTY; ++w_two) {
+ const int id_two = (get_group_id(1)*PAD_WPTY + w_two) * PAD_DIMY + get_local_id(1);
+ if (id_two < dest_dim && id_one < dest_dim) {
+
+ // Loads data from the lower-triangular matrix
+ real result;
+ SetToZero(result);
+ if (id_two < src_dim && id_one < src_dim) {
+ if (id_two <= id_one) { result = src[id_two*src_ld + id_one + src_offset]; }
+ if (id_two == id_one && unit_diagonal) { SetToOne(result); }
+ // Else: result is zero
+ }
+
+ // Stores the result in the destination matrix
+ dest[id_two*dest_ld + id_one + dest_offset] = result;
+ }
+ }
+ }
+}
+
+// Same as above, but now the matrix' data is stored in the upper-triangle
+__attribute__((reqd_work_group_size(PAD_DIMX, PAD_DIMY, 1)))
+__kernel void TrmmUpperToSquared(const int src_dim,
+ const int src_ld, const int src_offset,
+ __global const real* restrict src,
+ const int dest_dim,
+ const int dest_ld, const int dest_offset,
+ __global real* dest,
+ const int unit_diagonal) {
+
+ // Loops over the work per thread in both dimensions
+ #pragma unroll
+ for (int w_one=0; w_one<PAD_WPTX; ++w_one) {
+ const int id_one = (get_group_id(0)*PAD_WPTX + w_one) * PAD_DIMX + get_local_id(0);
+ #pragma unroll
+ for (int w_two=0; w_two<PAD_WPTY; ++w_two) {
+ const int id_two = (get_group_id(1)*PAD_WPTY + w_two) * PAD_DIMY + get_local_id(1);
+ if (id_two < dest_dim && id_one < dest_dim) {
+
+ // Loads data from the upper-triangular matrix
+ real result;
+ SetToZero(result);
+ if (id_two < src_dim && id_one < src_dim) {
+ if (id_one <= id_two) { result = src[id_two*src_ld + id_one + src_offset]; }
+ if (id_one == id_two && unit_diagonal) { SetToOne(result); }
+ // Else: result is zero
+ }
+
+ // Stores the result in the destination matrix
+ dest[id_two*dest_ld + id_one + dest_offset] = result;
}
}
}
diff --git a/src/routines/xtrmm.cc b/src/routines/xtrmm.cc
new file mode 100644
index 00000000..543df844
--- /dev/null
+++ b/src/routines/xtrmm.cc
@@ -0,0 +1,135 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xtrmm class (see the header for information about the class).
+//
+// =================================================================================================
+
+#include "internal/routines/xtrmm.h"
+
+#include <string>
+#include <vector>
+
+namespace clblast {
+// =================================================================================================
+
+// Constructor: forwards to base class constructor
+template <typename T>
+Xtrmm<T>::Xtrmm(CommandQueue &queue, Event &event):
+ Xgemm<T>(queue, event) {
+}
+
+// =================================================================================================
+
+// The main routine
+template <typename T>
+StatusCode Xtrmm<T>::DoTrmm(const Layout layout, const Side side, const Triangle triangle,
+ const Transpose a_transpose, const Diagonal diagonal,
+ const size_t m, const size_t n,
+ const T alpha,
+ const Buffer &a_buffer, const size_t a_offset, const size_t a_ld,
+ const Buffer &b_buffer, const size_t b_offset, const size_t b_ld) {
+
+ // Makes sure all dimensions are larger than zero
+ if ((m == 0) || (n == 0)) { return StatusCode::kInvalidDimension; }
+
+ // Computes the k dimension. This is based on whether or not matrix is A (on the left)
+ // or B (on the right) in the Xgemm routine.
+ auto k = (side == Side::kLeft) ? m : n;
+
+ // Checks for validity of the triangular A matrix
+ auto status = TestMatrixA(k, k, a_buffer, a_offset, a_ld, sizeof(T));
+ if (ErrorIn(status)) { return status; }
+
+ // Determines which kernel to run based on the layout (the Xgemm kernel assumes column-major as
+ // default) and on whether we are dealing with an upper or lower triangle of the triangular matrix
+ bool is_upper = ((triangle == Triangle::kUpper && layout != Layout::kRowMajor) ||
+ (triangle == Triangle::kLower && layout == Layout::kRowMajor));
+ auto kernel_name = (is_upper) ? "TrmmUpperToSquared" : "TrmmLowerToSquared";
+
+ // Determines whether or not the triangular matrix is unit-diagonal
+ auto unit_diagonal = (diagonal == Diagonal::kUnit) ? true : false;
+
+ // Temporary buffer for a copy of the triangular matrix
+ try {
+ auto temp_triangular = Buffer(context_, CL_MEM_READ_WRITE, k*k*sizeof(T));
+
+ // Creates a general matrix from the triangular matrix to be able to run the regular Xgemm
+ // routine afterwards
+ try {
+ auto& program = GetProgramFromCache();
+ auto kernel = Kernel(program, kernel_name);
+
+ // Sets the arguments for the triangular-to-squared kernel
+ kernel.SetArgument(0, static_cast<int>(k));
+ kernel.SetArgument(1, static_cast<int>(a_ld));
+ kernel.SetArgument(2, static_cast<int>(a_offset));
+ kernel.SetArgument(3, a_buffer());
+ kernel.SetArgument(4, static_cast<int>(k));
+ kernel.SetArgument(5, static_cast<int>(k));
+ kernel.SetArgument(6, static_cast<int>(0));
+ kernel.SetArgument(7, temp_triangular());
+ kernel.SetArgument(8, static_cast<int>(unit_diagonal));
+
+ // Uses the common padding kernel's thread configuration. This is allowed, since the
+ // triangular-to-squared kernel uses the same parameters.
+ auto global = std::vector<size_t>{Ceil(CeilDiv(k, db_["PAD_WPTX"]), db_["PAD_DIMX"]),
+ Ceil(CeilDiv(k, db_["PAD_WPTY"]), db_["PAD_DIMY"])};
+ auto local = std::vector<size_t>{db_["PAD_DIMX"], db_["PAD_DIMY"]};
+ status = RunKernel(kernel, global, local);
+ if (ErrorIn(status)) { return status; }
+
+ // Runs the regular Xgemm code with either "B := alpha*A*B" or ...
+ if (side == Side::kLeft) {
+ status = DoGemm(layout, a_transpose, Transpose::kNo,
+ m, n, k,
+ alpha,
+ temp_triangular, 0, k,
+ b_buffer, b_offset, b_ld,
+ static_cast<T>(0.0),
+ b_buffer, b_offset, b_ld);
+ }
+
+ // ... with "B := alpha*B*A". Note that A and B are now reversed.
+ else {
+ status = DoGemm(layout, Transpose::kNo, a_transpose,
+ m, n, k,
+ alpha,
+ b_buffer, b_offset, b_ld,
+ temp_triangular, 0, k,
+ static_cast<T>(0.0),
+ b_buffer, b_offset, b_ld);
+
+ // A and B are now reversed, so also reverse the error codes returned from the Xgemm routine
+ switch(status) {
+ case StatusCode::kInvalidMatrixA: status = StatusCode::kInvalidMatrixB; break;
+ case StatusCode::kInvalidMatrixB: status = StatusCode::kInvalidMatrixA; break;
+ case StatusCode::kInvalidLeadDimA: status = StatusCode::kInvalidLeadDimB; break;
+ case StatusCode::kInvalidLeadDimB: status = StatusCode::kInvalidLeadDimA; break;
+ case StatusCode::kInsufficientMemoryA: status = StatusCode::kInsufficientMemoryB; break;
+ case StatusCode::kInsufficientMemoryB: status = StatusCode::kInsufficientMemoryA; break;
+ }
+ }
+
+ // Return the status of the Xgemm routine
+ return status;
+ } catch (...) { return StatusCode::kInvalidKernel; }
+ } catch (...) { return StatusCode::kTempBufferAllocFailure; }
+}
+
+// =================================================================================================
+
+// Compiles the templated class
+template class Xtrmm<float>;
+template class Xtrmm<double>;
+template class Xtrmm<float2>;
+template class Xtrmm<double2>;
+
+// =================================================================================================
+} // namespace clblast
diff --git a/test/correctness/routines/xtrmm.cc b/test/correctness/routines/xtrmm.cc
new file mode 100644
index 00000000..943fb664
--- /dev/null
+++ b/test/correctness/routines/xtrmm.cc
@@ -0,0 +1,96 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the tests for the Xtrmm routine.
+//
+// =================================================================================================
+
+#include "correctness/testblas.h"
+#include "routines/xtrmm.h"
+
+namespace clblast {
+// =================================================================================================
+
+// The correctness tester
+template <typename T>
+void RunTest(int argc, char *argv[], const bool silent, const std::string &name) {
+
+ // Creates a tester
+ TestBlas<T> tester{argc, argv, silent, name, TestXtrmm<T>::GetOptions(),
+ TestXtrmm<T>::RunRoutine, TestXtrmm<T>::RunReference,
+ TestXtrmm<T>::DownloadResult, TestXtrmm<T>::GetResultIndex,
+ TestXtrmm<T>::ResultID1, TestXtrmm<T>::ResultID2};
+
+ // This variable holds the arguments relevant for this routine
+ auto args = Arguments<T>{};
+
+ // Loops over the test-cases from a data-layout point of view
+ for (auto &layout: tester.kLayouts) { args.layout = layout;
+ for (auto &side: tester.kSides) { args.side = side;
+ for (auto &triangle: tester.kTriangles) { args.triangle = triangle;
+ for (auto &a_transpose: tester.kTransposes) { args.a_transpose = a_transpose;
+ for (auto &diagonal: tester.kDiagonals) { args.diagonal = diagonal;
+
+ // Creates the arguments vector for the regular tests
+ auto regular_test_vector = std::vector<Arguments<T>>{};
+ for (auto &m: tester.kMatrixDims) { args.m = m;
+ for (auto &n: tester.kMatrixDims) { args.n = n;
+ for (auto &a_ld: tester.kMatrixDims) { args.a_ld = a_ld;
+ for (auto &a_offset: tester.kOffsets) { args.a_offset = a_offset;
+ for (auto &b_ld: tester.kMatrixDims) { args.b_ld = b_ld;
+ for (auto &b_offset: tester.kOffsets) { args.b_offset = b_offset;
+ for (auto &alpha: tester.kAlphaValues) { args.alpha = alpha;
+ args.a_size = TestXtrmm<T>::GetSizeA(args);
+ args.b_size = TestXtrmm<T>::GetSizeB(args);
+ if (args.a_size<1 || args.b_size<1) { continue; }
+ regular_test_vector.push_back(args);
+ }
+ }
+ }
+ }
+ }
+ }
+ }
+
+ // Creates the arguments vector for the invalid-buffer tests
+ auto invalid_test_vector = std::vector<Arguments<T>>{};
+ args.m = args.n = tester.kBufferSize;
+ args.a_ld = args.b_ld = tester.kBufferSize;
+ args.a_offset = args.b_offset = 0;
+ for (auto &a_size: tester.kMatSizes) { args.a_size = a_size;
+ for (auto &b_size: tester.kMatSizes) { args.b_size = b_size;
+ invalid_test_vector.push_back(args);
+ }
+ }
+
+ // Runs the tests
+ const auto case_name = ToString(layout)+" "+ToString(side)+" "+ToString(triangle)+" "+
+ ToString(a_transpose)+" "+ToString(diagonal);
+ tester.TestRegular(regular_test_vector, case_name);
+ tester.TestInvalid(invalid_test_vector, case_name);
+ }
+ }
+ }
+ }
+ }
+}
+
+// =================================================================================================
+} // namespace clblast
+
+// Main function (not within the clblast namespace)
+int main(int argc, char *argv[]) {
+ clblast::RunTest<float>(argc, argv, false, "STRMM");
+ clblast::RunTest<double>(argc, argv, true, "DTRMM");
+ clblast::RunTest<clblast::float2>(argc, argv, true, "CTRMM");
+ clblast::RunTest<clblast::double2>(argc, argv, true, "ZTRMM");
+ return 0;
+}
+
+// =================================================================================================
diff --git a/test/performance/graphs/xtrmm.r b/test/performance/graphs/xtrmm.r
new file mode 100644
index 00000000..4a3c2440
--- /dev/null
+++ b/test/performance/graphs/xtrmm.r
@@ -0,0 +1,127 @@
+
+# ==================================================================================================
+# This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+# project uses a tab-size of two spaces and a max-width of 100 characters per line.
+#
+# Author(s):
+# Cedric Nugteren <www.cedricnugteren.nl>
+#
+# This file implements the performance script for the Xtrmm routine
+#
+# ==================================================================================================
+
+# Includes the common functions
+args <- commandArgs(trailingOnly = FALSE)
+thisfile <- (normalizePath(sub("--file=", "", args[grep("--file=", args)])))
+source(file.path(dirname(thisfile), "common.r"))
+
+# ==================================================================================================
+
+# Settings
+routine_name <- "xtrmm"
+parameters <- c("-m","-n","-layout","-side","-triangle","-transA","-diagonal",
+ "-num_steps","-step","-runs","-precision")
+precision <- 32
+
+# Sets the names of the test-cases
+test_names <- list(
+ "multiples of 128",
+ "multiples of 128 (+1)",
+ "around m=n=512",
+ "around m=n=2048",
+ "layouts and side/triangle (m=n=1024)",
+ "powers of 2"
+)
+
+# Defines the test-cases
+test_values <- list(
+ list(c(128, 128, 0, 0, 0, 0, 0, 16, 128, num_runs, precision)),
+ list(c(129, 129, 0, 0, 0, 0, 0, 16, 128, num_runs, precision)),
+ list(c(512, 512, 0, 0, 0, 0, 0, 16, 1, num_runs, precision)),
+ list(c(2048, 2048, 0, 0, 0, 0, 0, 16, 1, num_runs, precision)),
+ list(
+ c(1024, 1024, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 1, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 1, 1, 1, 0, num_runs, precision),
+
+ c(1024, 1024, 0, 1, 0, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 0, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 0, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 0, 1, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 1, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 1, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 1, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 1, 1, 1, 1, 1, 0, num_runs, precision),
+
+ c(1024, 1024, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 1, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 1, 1, 1, 1, 0, num_runs, precision),
+
+ c(1024, 1024, 1, 1, 0, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 0, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 0, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 0, 1, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 1, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 1, 0, 1, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 1, 1, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 1, 1, 1, 1, 1, 1, 0, num_runs, precision)
+ ),
+ list(
+ c(8, 8, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(16, 16, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(32, 32, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(64, 64, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(128, 128, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(256, 256, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(512, 512, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(1024, 1024, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(2048, 2048, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(4096, 4096, 0, 0, 0, 0, 0, 1, 0, num_runs, precision),
+ c(8192, 8192, 0, 0, 0, 0, 0, 1, 0, num_runs, precision)
+ )
+)
+
+# Defines the x-labels corresponding to the test-cases
+test_xlabels <- list(
+ "matrix sizes (m=n)",
+ "matrix sizes (m=n)",
+ "matrix sizes (m=n)",
+ "matrix sizes (m=n)",
+ "layout (row/col), side (l/r), triangle (up/lo), transA (n/y), diag (u/nu)",
+ "matrix sizes (m=n)"
+)
+
+# Defines the x-axis of the test-cases
+test_xaxis <- list(
+ c("m", ""),
+ c("m", ""),
+ c("m", ""),
+ c("m", ""),
+ list(1:32, c("row,l,up,n,u", "row,l,up,n,nu", "row,l,up,y,u", "row,l,up,y,nu",
+ "row,r,up,n,u", "row,r,up,n,nu", "row,r,up,y,u", "row,r,up,y,nu",
+ "row,l,lo,n,u", "row,l,lo,n,nu", "row,l,lo,y,u", "row,l,lo,y,nu",
+ "row,r,lo,n,u", "row,r,lo,n,nu", "row,r,lo,y,u", "row,r,lo,y,nu",
+ "col,l,up,n,u", "col,l,up,n,nu", "col,l,up,y,u", "col,l,up,y,nu",
+ "col,r,up,n,u", "col,r,up,n,nu", "col,r,up,y,u", "col,r,up,y,nu",
+ "col,l,lo,n,u", "col,l,lo,n,nu", "col,l,lo,y,u", "col,l,lo,y,nu",
+ "col,r,lo,n,u", "col,r,lo,n,nu", "col,r,lo,y,u", "col,r,lo,y,nu")),
+ c("m", "x")
+)
+
+# ==================================================================================================
+
+# Start the script
+main(routine_name=routine_name, precision=precision, test_names=test_names, test_values=test_values,
+ test_xlabels=test_xlabels, test_xaxis=test_xaxis, metric_gflops=TRUE)
+
+# ================================================================================================== \ No newline at end of file
diff --git a/test/performance/routines/xtrmm.cc b/test/performance/routines/xtrmm.cc
new file mode 100644
index 00000000..91dcbd07
--- /dev/null
+++ b/test/performance/routines/xtrmm.cc
@@ -0,0 +1,36 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements the Xtrmm command-line interface performance tester.
+//
+// =================================================================================================
+
+#include "performance/client.h"
+#include "routines/xtrmm.h"
+
+// =================================================================================================
+
+// Main function (not within the clblast namespace)
+int main(int argc, char *argv[]) {
+ switch(clblast::GetPrecision(argc, argv)) {
+ case clblast::Precision::kHalf:
+ throw std::runtime_error("Unsupported precision mode");
+ case clblast::Precision::kSingle:
+ clblast::RunClient<clblast::TestXtrmm<float>, float>(argc, argv); break;
+ case clblast::Precision::kDouble:
+ clblast::RunClient<clblast::TestXtrmm<double>, double>(argc, argv); break;
+ case clblast::Precision::kComplexSingle:
+ clblast::RunClient<clblast::TestXtrmm<clblast::float2>, clblast::float2>(argc, argv); break;
+ case clblast::Precision::kComplexDouble:
+ clblast::RunClient<clblast::TestXtrmm<clblast::double2>, clblast::double2>(argc, argv); break;
+ }
+ return 0;
+}
+
+// =================================================================================================
diff --git a/test/routines/xtrmm.h b/test/routines/xtrmm.h
new file mode 100644
index 00000000..7b7e7af1
--- /dev/null
+++ b/test/routines/xtrmm.h
@@ -0,0 +1,127 @@
+
+// =================================================================================================
+// This file is part of the CLBlast project. The project is licensed under Apache Version 2.0. This
+// project loosely follows the Google C++ styleguide and uses a tab-size of two spaces and a max-
+// width of 100 characters per line.
+//
+// Author(s):
+// Cedric Nugteren <www.cedricnugteren.nl>
+//
+// This file implements a class with static methods to describe the Xtrmm routine. Examples of
+// such 'descriptions' are how to calculate the size a of buffer or how to run the routine. These
+// static methods are used by the correctness tester and the performance tester.
+//
+// =================================================================================================
+
+#ifndef CLBLAST_TEST_ROUTINES_XTRMM_H_
+#define CLBLAST_TEST_ROUTINES_XTRMM_H_
+
+#include <vector>
+#include <string>
+
+#include "wrapper_clblas.h"
+
+namespace clblast {
+// =================================================================================================
+
+// See comment at top of file for a description of the class
+template <typename T>
+class TestXtrmm {
+ public:
+
+ // The list of arguments relevant for this routine
+ static std::vector<std::string> GetOptions() {
+ return {kArgM, kArgN,
+ kArgLayout, kArgSide, kArgTriangle, kArgATransp, kArgDiagonal,
+ kArgALeadDim, kArgBLeadDim,
+ kArgAOffset, kArgBOffset,
+ kArgAlpha};
+ }
+
+ // Describes how to obtain the sizes of the buffers
+ static size_t GetSizeA(const Arguments<T> &args) {
+ auto k = (args.side == Side::kLeft) ? args.m : args.n;
+ return k * args.a_ld + args.a_offset;
+ }
+ static size_t GetSizeB(const Arguments<T> &args) {
+ auto b_rotated = (args.layout == Layout::kRowMajor);
+ auto b_two = (b_rotated) ? args.m : args.n;
+ return b_two * args.b_ld + args.b_offset;
+ }
+
+ // Describes how to set the sizes of all the buffers
+ static void SetSizes(Arguments<T> &args) {
+ args.a_size = GetSizeA(args);
+ args.b_size = GetSizeB(args);
+ }
+
+ // Describes what the default values of the leading dimensions of the matrices are
+ static size_t DefaultLDA(const Arguments<T> &args) { return args.m; }
+ static size_t DefaultLDB(const Arguments<T> &args) { return args.n; }
+ static size_t DefaultLDC(const Arguments<T> &) { return 1; } // N/A for this routine
+
+ // Describes how to run the CLBlast routine
+ static StatusCode RunRoutine(const Arguments<T> &args, const Buffers &buffers,
+ CommandQueue &queue) {
+ auto queue_plain = queue();
+ auto event = cl_event{};
+ auto status = Trmm(args.layout, args.side, args.triangle, args.a_transpose, args.diagonal,
+ args.m, args.n, args.alpha,
+ buffers.a_mat(), args.a_offset, args.a_ld,
+ buffers.b_mat(), args.b_offset, args.b_ld,
+ &queue_plain, &event);
+ clWaitForEvents(1, &event);
+ return status;
+ }
+
+ // Describes how to run the clBLAS routine (for correctness/performance comparison)
+ static StatusCode RunReference(const Arguments<T> &args, const Buffers &buffers,
+ CommandQueue &queue) {
+ auto queue_plain = queue();
+ auto event = cl_event{};
+ auto status = clblasXtrmm(static_cast<clblasOrder>(args.layout),
+ static_cast<clblasSide>(args.side),
+ static_cast<clblasUplo>(args.triangle),
+ static_cast<clblasTranspose>(args.a_transpose),
+ static_cast<clblasDiag>(args.diagonal),
+ args.m, args.n, args.alpha,
+ buffers.a_mat(), args.a_offset, args.a_ld,
+ buffers.b_mat(), args.b_offset, args.b_ld,
+ 1, &queue_plain, 0, nullptr, &event);
+ clWaitForEvents(1, &event);
+ return static_cast<StatusCode>(status);
+ }
+
+ // Describes how to download the results of the computation (more importantly: which buffer)
+ static std::vector<T> DownloadResult(const Arguments<T> &args, Buffers &buffers,
+ CommandQueue &queue) {
+ std::vector<T> result(args.b_size, static_cast<T>(0));
+ buffers.b_mat.ReadBuffer(queue, args.b_size*sizeof(T), result);
+ return result;
+ }
+
+ // Describes how to compute the indices of the result buffer
+ static size_t ResultID1(const Arguments<T> &args) { return args.m; }
+ static size_t ResultID2(const Arguments<T> &args) { return args.n; }
+ static size_t GetResultIndex(const Arguments<T> &args, const size_t id1, const size_t id2) {
+ return (args.layout == Layout::kRowMajor) ?
+ id1*args.b_ld + id2 + args.b_offset:
+ id2*args.b_ld + id1 + args.b_offset;
+ }
+
+ // Describes how to compute performance metrics
+ static size_t GetFlops(const Arguments<T> &args) {
+ auto k = (args.side == Side::kLeft) ? args.m : args.n;
+ return args.m * args.n * k;
+ }
+ static size_t GetBytes(const Arguments<T> &args) {
+ auto k = (args.side == Side::kLeft) ? args.m : args.n;
+ return (k*k + 2*args.m*args.n) * sizeof(T);
+ }
+};
+
+// =================================================================================================
+} // namespace clblast
+
+// CLBLAST_TEST_ROUTINES_XTRMM_H_
+#endif