summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb2d847d..b0a2759c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -577,7 +577,10 @@ if(TESTS)
endforeach()
# Miscellaneous tests
- set(MISC_TESTS override_parameters preprocessor)
+ set(MISC_TESTS override_parameters)
+ if(NOT CUDA)
+ set(MISC_TESTS ${MISC_TESTS} preprocessor)
+ endif()
if(MSVC)
set(TESTS_COMMON ${TESTS_COMMON} src/kernel_preprocessor.cpp)
endif()