summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c882575e..ae78b5a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -218,6 +218,14 @@ install(FILES include/clblast_half.h DESTINATION include)
# Installs the config for find_package in dependent projects
install(EXPORT CLBlast DESTINATION lib/cmake/CLBLast FILE CLBlastConfig.cmake)
+# Install pkg-config file on Linux
+if(UNIX)
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/src/clblast.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/clblast.pc" @ONLY IMMEDIATE)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/clblast.pc
+ DESTINATION lib/pkgconfig)
+endif()
+
# ==================================================================================================
# Sets a default platform ($CLBLAST_PLATFORM) and device ($CLBLAST_DEVICE) to run tuners and tests