summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48aaefe9..21254ded 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -226,10 +226,20 @@ if(TESTS)
if(CLBLAS_FOUND)
set(REF_INCLUDES ${REF_INCLUDES} ${CLBLAS_INCLUDE_DIRS})
set(REF_LIBRARIES ${REF_LIBRARIES} ${CLBLAS_LIBRARIES})
+ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
+ add_definitions(" /DCLBLAST_REF_CLBLAS")
+ else()
+ add_definitions(" -DCLBLAST_REF_CLBLAS")
+ endif()
endif()
if(CBLAS_FOUND)
set(REF_INCLUDES ${REF_INCLUDES} ${CBLAS_INCLUDE_DIRS})
set(REF_LIBRARIES ${REF_LIBRARIES} ${CBLAS_LIBRARIES})
+ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
+ add_definitions(" /DCLBLAST_REF_CBLAS")
+ else()
+ add_definitions(" -DCLBLAST_REF_CBLAS")
+ endif()
endif()
# Sets the include directories