summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 595c6b89..049662b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,10 @@ else()
set(FLAGS "${FLAGS} -Wno-missing-prototypes -Wno-float-equal -Wno-switch-enum -Wno-switch")
set(FLAGS "${FLAGS} -Wno-exit-time-destructors -Wno-global-constructors -Wno-missing-noreturn")
set(FLAGS "${FLAGS} -Wno-deprecated-declarations")
- if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0)
- set(FLAGS "${FLAGS} -Wno-undefined-var-template")
+ if(NOT CMAKE_CXX_COMPILER_ID MATCHES AppleClang)
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 3.9.0)
+ set(FLAGS "${FLAGS} -Wno-undefined-var-template")
+ endif()
endif()
endif()
endif()