summaryrefslogtreecommitdiff
path: root/external/clBLAS/src/library/blas/gens/legacy/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/clBLAS/src/library/blas/gens/legacy/tests/CMakeLists.txt')
-rw-r--r--external/clBLAS/src/library/blas/gens/legacy/tests/CMakeLists.txt55
1 files changed, 0 insertions, 55 deletions
diff --git a/external/clBLAS/src/library/blas/gens/legacy/tests/CMakeLists.txt b/external/clBLAS/src/library/blas/gens/legacy/tests/CMakeLists.txt
deleted file mode 100644
index fae11cc5..00000000
--- a/external/clBLAS/src/library/blas/gens/legacy/tests/CMakeLists.txt
+++ /dev/null
@@ -1,55 +0,0 @@
-# ########################################################################
-# Copyright 2013 Advanced Micro Devices, Inc.
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-# ########################################################################
-
-
-set(SRC_BLKMUL
- ../blkmul.c
- ${clBLAS_SOURCE_DIR}/library/common/kerngen_core.c
- ${clBLAS_SOURCE_DIR}/library/common/kgen_basic.c
- ${clBLAS_SOURCE_DIR}/library/common/kgen_loop_helper.c
- ${clBLAS_SOURCE_DIR}/library/common/misc.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/blas_kgen.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/tile.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/tile_iter.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/legacy/blas_kgen_legacy.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/gen_helper.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/legacy/gen_helper_legacy.c
- ${clBLAS_SOURCE_DIR}/library/blas/generic/blas_funcs.c
- ${clBLAS_SOURCE_DIR}/library/blas/generic/matrix_dims.c
- ${clBLAS_SOURCE_DIR}/library/blas/generic/matrix_props.c
- ${clBLAS_SOURCE_DIR}/library/common/gens/dblock_kgen.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/tilemul.c
- ${clBLAS_SOURCE_DIR}/library/blas/gens/fetch.c
- ${clBLAS_SOURCE_DIR}/library/common/kgen_guard.c
- ${clBLAS_SOURCE_DIR}/library/common/list.c
- ${clBLAS_SOURCE_DIR}/library/common/mutex.c
- ${clBLAS_SOURCE_DIR}/library/common/trace_malloc.c
- t_blkmul.c
-)
-
-include_directories(${OPENCL_INCLUDE_DIRS} ${clBLAS_SOURCE_DIR} ${clBLAS_SOURCE_DIR}/include
- ${clBLAS_SOURCE_DIR}/library/blas/include ${clBLAS_SOURCE_DIR}/library/blas/gens)
-
-add_executable(t_blkmul ${SRC_BLKMUL})
-target_link_libraries(t_blkmul ${OPENCL_LIBRARIES})
-set_target_properties( t_blkmul PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
-
-# CPack configuration; include the executable into the package
-install( TARGETS t_blkmul
- RUNTIME DESTINATION bin${SUFFIX_BIN}
- LIBRARY DESTINATION lib${SUFFIX_LIB}
- ARCHIVE DESTINATION lib${SUFFIX_LIB}/import
- )