summaryrefslogtreecommitdiff
path: root/src/pyclblast/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'src/pyclblast/README.md')
-rw-r--r--src/pyclblast/README.md8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/pyclblast/README.md b/src/pyclblast/README.md
index 2f6ebed7..a6a55907 100644
--- a/src/pyclblast/README.md
+++ b/src/pyclblast/README.md
@@ -30,6 +30,14 @@ After installation OpenCL and CLBlast, simply use pip to install PyCLBlast, e.g.
To start using the library, browse the [CLBlast](https://github.com/CNugteren/CLBlast) documentation or check out the PyCLBlast samples provides in the `samples` subfolder.
+For developers, first install CLBlast, followed by the Python requirements (e.g. in a Python3 virtualenv):
+
+ pip install Cython numpy pybind11
+ pip install pyopencl
+
+And then compile the library from this location using the `setup.py` file:
+
+ python setup.py install
Testing PyCLBlast
-------------