summaryrefslogtreecommitdiff
path: root/.appveyor.yml
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2020-07-02 00:32:34 -0700
committerGitHub <noreply@github.com>2020-07-02 00:32:34 -0700
commit5131abd569ae5c4f11e753f1a6dc1ee232bcb96f (patch)
tree786e04a0b9ead4620d5fcdf7cb67befeaf4646f2 /.appveyor.yml
parent8d316e831c6af51efb9c362a5b203528a9fd3b15 (diff)
parentf39473b7c1de0fe42b3f4ebf5cb37bca0a84a247 (diff)
Merge pull request #355 from VincentRouvreau/alpha_complex_3d_python
Alpha complex is using 3d version in dim 3
Diffstat (limited to '.appveyor.yml')
-rw-r--r--.appveyor.yml17
1 files changed, 9 insertions, 8 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index d072a366..a257debc 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -11,23 +11,23 @@ configuration:
environment:
# update the vcpkg cache even if build fails
APPVEYOR_SAVE_CACHE_ON_ERROR: true
+ PYTHON: "C:\\Python37-x64"
+ CMAKE_GMP_FLAGS: -DGMP_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpir.lib"
+ CMAKE_MPFR_FLAGS: -DMPFR_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DMPFR_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpfr.lib"
+ CMAKE_VCPKG_FLAGS: -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake
matrix:
- target: Examples
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=ON -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF
- PYTHON: "C:\\Python37-x64"
- target: UnitaryTests
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=ON -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=OFF
- PYTHON: "C:\\Python37-x64"
- target: Utilities
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=ON -DWITH_GUDHI_PYTHON=OFF
- PYTHON: "C:\\Python37-x64"
- target: Python
CMAKE_FLAGS: -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_TEST=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON
- PYTHON: "C:\\Python37-x64"
cache:
@@ -37,17 +37,17 @@ cache:
init:
- echo %target%
-
+# tbb:x64-windows
install:
- git submodule update --init
- - vcpkg install tbb:x64-windows boost-disjoint-sets:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows mpfr:x64-windows mpir:x64-windows cgal:x64-windows
+ - vcpkg install boost-disjoint-sets:x64-windows boost-serialization:x64-windows boost-date-time:x64-windows boost-system:x64-windows boost-filesystem:x64-windows boost-units:x64-windows boost-thread:x64-windows boost-program-options:x64-windows eigen3:x64-windows mpfr:x64-windows mpir:x64-windows cgal:x64-windows
- SET PATH=c:\Tools\vcpkg\installed\x64-windows\bin;%PATH%
- SET PATH=%PYTHON%;%PYTHON%\Scripts;%PYTHON%\Library\bin;%PATH%
- SET PYTHONPATH=%PYTHON%\\Lib\\site-packages;%PYTHONPATH%
- CALL "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat" amd64
- python --version
- pip --version
- - python -m pip install --upgrade pip
+ - python -m pip install --user --upgrade pip
- python -m pip install --user -r .github/build-requirements.txt
# No PyKeOps on windows, let's workaround this one.
- for /F "tokens=*" %%A in (.github/test-requirements.txt) do python -m pip install --user %%A
@@ -55,9 +55,10 @@ install:
build_script:
- mkdir build
- cd build
- - cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% -DGMP_INCLUDE_DIR="c:/Tools/vcpkg/installed/x64-windows/include" -DGMP_LIBRARIES="c:/Tools/vcpkg/installed/x64-windows/lib/mpir.lib" -DGMP_LIBRARIES_DIR="c:/Tools/vcpkg/installed/x64-windows/lib" -DCMAKE_TOOLCHAIN_FILE=c:/Tools/vcpkg/scripts/buildsystems/vcpkg.cmake ..
+ - cmake -G "Visual Studio 15 2017 Win64" %CMAKE_FLAGS% %CMAKE_GMP_FLAGS% %CMAKE_MPFR_FLAGS% %CMAKE_VCPKG_FLAGS% ..
- if [%target%]==[Python] (
cd src/python &
+ type setup.py &
MSBuild Cython.sln /m /p:Configuration=Release /p:Platform=x64 &
ctest -j 1 --output-on-failure -C Release
) else (