summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormathieu <mathieu.carriere3@gmail.com>2020-02-06 10:47:46 -0500
committermathieu <mathieu.carriere3@gmail.com>2020-02-06 10:47:46 -0500
commitd21640a16113a3c56389efcb060b3430af9f256d (patch)
treeb4238c8493310ff50d82cf076d082efacf4ff13f
parentee1bb650858e0c9f8d2e6ce988174acf2cc9834a (diff)
parent055fda8507fde336a21169f10b3fd0782886e472 (diff)
Merge branch 'master' of https://github.com/GUDHI/gudhi-devel into wasserstein_representations
-rw-r--r--.circleci/config.yml10
-rw-r--r--Dockerfile_for_circleci_image1
-rw-r--r--src/python/setup.py.in2
3 files changed, 9 insertions, 4 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index 5e45bc14..f4073746 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -45,6 +45,7 @@ jobs:
python:
docker:
- image: gudhi/ci_for_gudhi:latest
+ parallelism: 4
steps:
- checkout
- run:
@@ -58,10 +59,13 @@ jobs:
mkdir build;
cd build;
cmake -DCMAKE_BUILD_TYPE=Release -DWITH_GUDHI_EXAMPLE=OFF -DWITH_GUDHI_UTILITIES=OFF -DWITH_GUDHI_PYTHON=ON -DPython_ADDITIONAL_VERSIONS=3 ..;
- make all;
- ctest --output-on-failure;
+ cd python;
+ python3 setup.py build_ext -j 4 --inplace;
make sphinx;
- cp -R python/sphinx /tmp/sphinx;
+ cp -R sphinx /tmp/sphinx;
+ python3 setup.py install;
+ python3 setup.py clean --all;
+ ctest -j 4 --output-on-failure;
- store_artifacts:
path: /tmp/sphinx
diff --git a/Dockerfile_for_circleci_image b/Dockerfile_for_circleci_image
index ff4e6018..b7d0dcca 100644
--- a/Dockerfile_for_circleci_image
+++ b/Dockerfile_for_circleci_image
@@ -49,6 +49,7 @@ RUN apt-get install -y make \
pkg-config
RUN pip3 install \
+ setuptools \
numpy \
matplotlib \
scipy \
diff --git a/src/python/setup.py.in b/src/python/setup.py.in
index 9c2124f4..f993165c 100644
--- a/src/python/setup.py.in
+++ b/src/python/setup.py.in
@@ -44,7 +44,7 @@ for module in modules:
setup(
name = 'gudhi',
- packages=["gudhi",],
+ packages=["gudhi","gudhi.representations"],
author='GUDHI Editorial Board',
author_email='gudhi-contact@lists.gforge.inria.fr',
version='@GUDHI_VERSION@',