summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2021-12-16 11:14:42 +0100
committerGitHub <noreply@github.com>2021-12-16 11:14:42 +0100
commit9d1558e64abc6ecd31a476cafb97ca01587e796e (patch)
tree0acf1dbe17edfe444f2f0a8fe0aa00efa56e35b6
parent6880bce525322cc085a3d8671601145d153e29a8 (diff)
parent971316e7a565f92954397f420a64a073155e41f5 (diff)
Merge pull request #555 from Hind-M/benchmark_debug_tbb
Fix benchmarks compilation errors in debug mode
-rw-r--r--src/Toplex_map/benchmark/CMakeLists.txt4
-rw-r--r--src/common/benchmark/CMakeLists.txt4
2 files changed, 8 insertions, 0 deletions
diff --git a/src/Toplex_map/benchmark/CMakeLists.txt b/src/Toplex_map/benchmark/CMakeLists.txt
index 2d58a156..6703d9d0 100644
--- a/src/Toplex_map/benchmark/CMakeLists.txt
+++ b/src/Toplex_map/benchmark/CMakeLists.txt
@@ -1,3 +1,7 @@
project(Toplex_map_benchmark)
add_executable(Toplex_map_benchmark benchmark_tm.cpp)
+
+if (TBB_FOUND)
+ target_link_libraries(Toplex_map_benchmark ${TBB_LIBRARIES})
+endif()
diff --git a/src/common/benchmark/CMakeLists.txt b/src/common/benchmark/CMakeLists.txt
index a3787d6e..26e4e6af 100644
--- a/src/common/benchmark/CMakeLists.txt
+++ b/src/common/benchmark/CMakeLists.txt
@@ -1,3 +1,7 @@
project(common_benchmark)
add_executable(Graph_simplicial_complex_benchmark Graph_simplicial_complex_benchmark.cpp)
+
+if (TBB_FOUND)
+ target_link_libraries(Graph_simplicial_complex_benchmark ${TBB_LIBRARIES})
+endif()