summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpdlotko <pdlotko@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-04-07 10:32:07 +0000
committerpdlotko <pdlotko@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-04-07 10:32:07 +0000
commit032b937da93d45ca55464092f25c104790dd75a6 (patch)
tree586c1ebce01370ad7cfee487de66ed53db9e77a6
parentca2ad986b9925ab7006597f0f7045f7be47a42b2 (diff)
Adding a new reading method for persistence diagrams.
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/gudhi_stat@2318 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: dd4dcc3da249ae938674d3bd4db537ac982368c0
-rw-r--r--src/Gudhi_stat/test/CMakeLists.txt10
-rw-r--r--src/Gudhi_stat/test/data/persistence_file_with_four_entries_per_line11
-rw-r--r--src/Gudhi_stat/test/data/persistence_file_with_three_entries_per_line11
-rw-r--r--src/Gudhi_stat/test/data/persistence_file_with_two_entries_per_line8
-rw-r--r--src/Gudhi_stat/test/read_persistence_from_file_test.cpp115
5 files changed, 155 insertions, 0 deletions
diff --git a/src/Gudhi_stat/test/CMakeLists.txt b/src/Gudhi_stat/test/CMakeLists.txt
index 4ae09663..3018dc1d 100644
--- a/src/Gudhi_stat/test/CMakeLists.txt
+++ b/src/Gudhi_stat/test/CMakeLists.txt
@@ -68,3 +68,13 @@ add_test(NAME persistence_heat_maps_test
COMMAND ${CMAKE_CURRENT_BINARY_DIR}/persistence_heat_maps_test
# XML format for Jenkins xUnit plugin
--log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/persistence_heat_maps_UT.xml --log_level=test_suite --report_level=no)
+
+
+add_executable ( read_persistence_from_file_test read_persistence_from_file_test.cpp )
+target_link_libraries(read_persistence_from_file_test ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+
+# Unitary tests
+add_test(NAME read_persistence_from_file_test
+ COMMAND ${CMAKE_CURRENT_BINARY_DIR}/read_persistence_from_file_test
+ # XML format for Jenkins xUnit plugin
+ --log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/read_persistence_from_file_UT.xml --log_level=test_suite --report_level=no)
diff --git a/src/Gudhi_stat/test/data/persistence_file_with_four_entries_per_line b/src/Gudhi_stat/test/data/persistence_file_with_four_entries_per_line
new file mode 100644
index 00000000..04303cb1
--- /dev/null
+++ b/src/Gudhi_stat/test/data/persistence_file_with_four_entries_per_line
@@ -0,0 +1,11 @@
+1 2 10 inf
+#this is a comment
+2 4 1 0
+# this is another comment
+1 1 2 0
+5 2 50 0
+#and here we have line with infnity:
+1 1 10 inf
+#and another comment
+1 1 10 90
+2 1 4 4 \ No newline at end of file
diff --git a/src/Gudhi_stat/test/data/persistence_file_with_three_entries_per_line b/src/Gudhi_stat/test/data/persistence_file_with_three_entries_per_line
new file mode 100644
index 00000000..8e0fc3df
--- /dev/null
+++ b/src/Gudhi_stat/test/data/persistence_file_with_three_entries_per_line
@@ -0,0 +1,11 @@
+1 4 inf
+#this is a comment
+4 1 0
+# this is another comment
+ 1 1 0
+ 2 50 0
+#and here we have line with infnity:
+ 1 1 inf
+#and another comment
+1 10 90
+1 4 4
diff --git a/src/Gudhi_stat/test/data/persistence_file_with_two_entries_per_line b/src/Gudhi_stat/test/data/persistence_file_with_two_entries_per_line
new file mode 100644
index 00000000..24aaea7b
--- /dev/null
+++ b/src/Gudhi_stat/test/data/persistence_file_with_two_entries_per_line
@@ -0,0 +1,8 @@
+4 10
+#this is a comment
+4 inf
+# this is another comment
+1 0
+#and here we have line with infnity:
+1 4
+#and here we have line with infnity:
diff --git a/src/Gudhi_stat/test/read_persistence_from_file_test.cpp b/src/Gudhi_stat/test/read_persistence_from_file_test.cpp
new file mode 100644
index 00000000..ed26ba28
--- /dev/null
+++ b/src/Gudhi_stat/test/read_persistence_from_file_test.cpp
@@ -0,0 +1,115 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+
+#define BOOST_TEST_DYN_LINK
+#define BOOST_TEST_MODULE "gudhi_stat"
+#include <boost/test/unit_test.hpp>
+#include <gudhi/reader_utils.h>
+#include <gudhi/read_persitence_from_file.h>
+
+#include <iostream>
+
+
+
+using namespace Gudhi;
+using namespace Gudhi::Gudhi_stat;
+
+
+
+
+
+BOOST_AUTO_TEST_CASE(test_read_file_with_four_elements_per_line)
+{
+ std::vector< std::pair< double,double > > what_we_should_get;
+ what_we_should_get.push_back( std::make_pair( 0 , 2 ) );
+ what_we_should_get.push_back( std::make_pair( 10 , 1000 ) );
+ what_we_should_get.push_back( std::make_pair( 10 , 90 ) );
+ what_we_should_get.push_back( std::make_pair( 4 , 4 ) );
+ std::vector<std::pair<double,double> > what_we_get = read_persistence_intervals_in_one_dimension_from_file("data/persistence_file_with_four_entries_per_line" , 1 , 1000 );
+
+
+ //for ( size_t i = 0 ; i != what_we_get.size() ; ++i )
+ //{
+ // std::cerr << what_we_get[i].first << " , " << what_we_get[i].second << std::endl;
+ //}
+
+ BOOST_CHECK( what_we_should_get.size() == what_we_get.size() );
+
+ for ( size_t i = 0 ; i != what_we_get.size() ; ++i )
+ {
+ BOOST_CHECK( what_we_should_get[i] == what_we_get[i] );
+ }
+}
+
+
+BOOST_AUTO_TEST_CASE(test_read_file_with_three_elements_per_line)
+{
+ std::vector< std::pair< double,double > > what_we_should_get;
+ what_we_should_get.push_back( std::make_pair( 4 , 9999 ) );
+ what_we_should_get.push_back( std::make_pair( 0 , 1 ) );
+ what_we_should_get.push_back( std::make_pair( 1 , 9999 ) );
+ what_we_should_get.push_back( std::make_pair( 10 , 90 ) );
+ what_we_should_get.push_back( std::make_pair( 4 , 4 ) );
+
+ std::vector<std::pair<double,double> > what_we_get = read_persistence_intervals_in_one_dimension_from_file("data/persistence_file_with_three_entries_per_line" , 1 , 9999 );
+
+
+ //for ( size_t i = 0 ; i != what_we_get.size() ; ++i )
+ //{
+ // std::cerr << what_we_get[i].first << " , " << what_we_get[i].second << std::endl;
+ //}
+
+ BOOST_CHECK( what_we_should_get.size() == what_we_get.size() );
+
+ for ( size_t i = 0 ; i != what_we_get.size() ; ++i )
+ {
+ BOOST_CHECK( what_we_should_get[i] == what_we_get[i] );
+ }
+}
+
+
+BOOST_AUTO_TEST_CASE(test_read_file_with_two_elements_per_line)
+{
+ std::vector< std::pair< double,double > > what_we_should_get;
+ what_we_should_get.push_back( std::make_pair( 4 , 10 ) );
+ what_we_should_get.push_back( std::make_pair( 4 , 9999 ) );
+ what_we_should_get.push_back( std::make_pair( 0 , 1 ) );
+ what_we_should_get.push_back( std::make_pair( 1 , 4 ) );
+
+ std::vector<std::pair<double,double> > what_we_get = read_persistence_intervals_in_one_dimension_from_file("data/persistence_file_with_two_entries_per_line" , 1 , 9999 );
+
+
+ //for ( size_t i = 0 ; i != what_we_get.size() ; ++i )
+ //{
+ // std::cerr << what_we_get[i].first << " , " << what_we_get[i].second << std::endl;
+ //}
+
+ BOOST_CHECK( what_we_should_get.size() == what_we_get.size() );
+
+ for ( size_t i = 0 ; i != what_we_get.size() ; ++i )
+ {
+ BOOST_CHECK( what_we_should_get[i] == what_we_get[i] );
+ }
+}
+