summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-02-14 09:44:55 +0100
committerGitHub <noreply@github.com>2022-02-14 09:44:55 +0100
commitcead99a89dcb017e2e4da803de82823b52968c1c (patch)
tree846acbe40de31698d1c1e5121dec29b1128c3ac2
parent1f52ad91c945bb5ef2eaf6d08101de0a8354044b (diff)
parent1eae93c4f6c5fa401cf03dce0bcbc70e72d4f46f (diff)
Merge pull request #583 from VincentRouvreau/debug_traces_for_python
Debug traces for python module
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 8eb7478e..777fae72 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -264,6 +264,10 @@ if(PYTHONINTERP_FOUND)
set(GUDHI_PYTHON_INCLUDE_DIRS "${GUDHI_PYTHON_INCLUDE_DIRS}'${TBB_INCLUDE_DIRS}', ")
endif()
+ if(DEBUG_TRACES)
+ set(GUDHI_PYTHON_EXTRA_COMPILE_ARGS "${GUDHI_PYTHON_EXTRA_COMPILE_ARGS}'-DDEBUG_TRACES', ")
+ endif(DEBUG_TRACES)
+
if(UNIX AND WITH_GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS)
set( GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS "${GUDHI_PYTHON_LIBRARY_DIRS}")
endif(UNIX AND WITH_GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS)