summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-10-29 13:38:54 +0100
committerGard Spreemann <gspr@nonempty.org>2019-10-29 13:38:54 +0100
commit9a4d00224747d763c062062f924a0a96d975d113 (patch)
tree1f636d1e8f211a886a924670167a585749c17ca2
parent009d8b986d8e568e6f1146ca08db11279dbfb20c (diff)
Add x32 to memory-weak list.
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index decadfde..759a7ceb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,14 +15,14 @@ DHFLAGS+=--buildsystem=cmake
# The buildds run out of memory on some architectures. On those, we
# force non-parallel building.
-ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mipsel m68k powerpcspe))
+ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mipsel m68k powerpcspe x32))
export DEB_CXXFLAGS_MAINT_APPEND = --param ggc-min-expand=5
DHFLAGS+=--no-parallel
endif
# Disable tests on i386 due to rounding problem in some. See upstream GitHub issue #118.
# Disable tests on s390x, as a few are broken. See #943384.
-ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 s390x))
+ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 s390x x32))
export DEB_BUILD_MAINT_OPTIONS := $(DEB_BUILD_MAINT_OPTIONS) nocheck
endif