summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-12-16 16:12:00 +0100
committerGard Spreemann <gspr@nonempty.org>2020-12-17 13:41:15 +0100
commitffa79d8f6a1e0ebdc6e6de362af7a4195a1b63a4 (patch)
treef098c63f351c31e3317516533a3dfefcd4b19204
parent2fd4337a2b69a772e23c81dc03f60cde77bf38d5 (diff)
Refresh patches.
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch47
-rw-r--r--debian/patches/0005-Disable-Sphinx.patch4
-rw-r--r--debian/patches/0006-Install-Python-module-in-correct-location.patch4
-rw-r--r--debian/patches/0007-Move-towards-reproducible-builds.patch2
4 files changed, 32 insertions, 25 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 4b4f24f3..6151ae79 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -5,16 +5,16 @@ Subject: Disable tests that use DFSG-deleted data files.
---
src/Nerve_GIC/example/CMakeLists.txt | 5 ----
src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
- src/Persistent_cohomology/example/CMakeLists.txt | 4 ---
+ src/Persistent_cohomology/example/CMakeLists.txt | 12 ---------
src/Simplex_tree/example/CMakeLists.txt | 2 --
src/python/CMakeLists.txt | 31 +-----------------------
- 5 files changed, 1 insertion(+), 49 deletions(-)
+ 5 files changed, 1 insertion(+), 57 deletions(-)
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
-index 1667472..37c4759 100644
+index 4b0f467..110212d 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
-@@ -12,15 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+@@ -12,14 +12,9 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
# Copy files for not to pollute sources when testing
file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
@@ -28,8 +28,7 @@ index 1667472..37c4759 100644
- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
- install(TARGETS CoordGIC DESTINATION bin)
- install(TARGETS FuncGIC DESTINATION bin)
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
index 65a08d9..3f16db9 100644
--- a/src/Nerve_GIC/utilities/CMakeLists.txt
@@ -50,22 +49,30 @@ index 65a08d9..3f16db9 100644
install(TARGETS Nerve DESTINATION bin)
install(TARGETS VoronoiGIC DESTINATION bin)
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
-index 4c08cd6..a7a7bcd 100644
+index c68c652..9a15a89 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
-@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
- add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
--add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
--add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+@@ -33,18 +33,6 @@ if(TARGET Boost::program_options)
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+ endif()
- install(TARGETS plain_homology DESTINATION bin)
- install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+-if(TARGET Boost::program_options)
+- add_executable(persistence_from_file persistence_from_file.cpp)
+- target_link_libraries(persistence_from_file Boost::program_options)
+- if (TBB_FOUND)
+- target_link_libraries(persistence_from_file ${TBB_LIBRARIES})
+- endif()
+- add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+- add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+-endif()
+-
+ if(GMP_FOUND)
+ if(GMPXX_FOUND)
+ if(TARGET Boost::program_options)
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
-index a0aabee..5c572f8 100644
+index 73b2c6f..a6dd0b1 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -28,8 +28,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
@@ -78,10 +85,10 @@ index a0aabee..5c572f8 100644
endif()
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 4f26481..99b648b 100644
+index 5c1402a..a45e13a 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -381,36 +381,7 @@ if(PYTHONINTERP_FOUND)
+@@ -386,36 +386,7 @@ if(PYTHONINTERP_FOUND)
add_gudhi_py_test(test_bottleneck_distance)
endif()
diff --git a/debian/patches/0005-Disable-Sphinx.patch b/debian/patches/0005-Disable-Sphinx.patch
index 0df79e58..2aee22ff 100644
--- a/debian/patches/0005-Disable-Sphinx.patch
+++ b/debian/patches/0005-Disable-Sphinx.patch
@@ -7,10 +7,10 @@ Subject: Disable Sphinx.
1 file changed, 1 deletion(-)
diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-index a56a275..11b5b20 100644
+index e156687..aa1c4bb 100644
--- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
+++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-@@ -178,7 +178,6 @@ if( PYTHONINTERP_FOUND )
+@@ -147,7 +147,6 @@ if( PYTHONINTERP_FOUND )
find_python_module("matplotlib")
find_python_module("numpy")
find_python_module("scipy")
diff --git a/debian/patches/0006-Install-Python-module-in-correct-location.patch b/debian/patches/0006-Install-Python-module-in-correct-location.patch
index 0b4a8f64..a395cdd8 100644
--- a/debian/patches/0006-Install-Python-module-in-correct-location.patch
+++ b/debian/patches/0006-Install-Python-module-in-correct-location.patch
@@ -7,10 +7,10 @@ Subject: Install Python module in correct location.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 99b648b..162bd27 100644
+index a45e13a..4d56f58 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -267,7 +267,7 @@ if(PYTHONINTERP_FOUND)
+@@ -274,7 +274,7 @@ if(PYTHONINTERP_FOUND)
add_custom_target(python ALL DEPENDS gudhi.so
COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
diff --git a/debian/patches/0007-Move-towards-reproducible-builds.patch b/debian/patches/0007-Move-towards-reproducible-builds.patch
index 7e2f01db..7d6ae95d 100644
--- a/debian/patches/0007-Move-towards-reproducible-builds.patch
+++ b/debian/patches/0007-Move-towards-reproducible-builds.patch
@@ -9,7 +9,7 @@ but since we're not doing Sphinx stuff yet anyway, that is ok for now.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/python/gudhi/__init__.py.in b/src/python/gudhi/__init__.py.in
-index 79e12fb..991745a 100644
+index 3043201..ef6389e 100644
--- a/src/python/gudhi/__init__.py.in
+++ b/src/python/gudhi/__init__.py.in
@@ -15,7 +15,7 @@ __copyright__ = "Copyright (C) 2016 Inria"