summaryrefslogtreecommitdiff
path: root/debian/patches/0006-Install-Python-module-in-correct-location.patch
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-05-20 09:00:01 +0200
committerGard Spreemann <gspr@nonempty.org>2020-05-20 09:00:01 +0200
commit90ed3afb56f0e9fe4ef53f2e141239015a20bc08 (patch)
tree4e98c28ababf8f2865921b756259c51f0c3d215d /debian/patches/0006-Install-Python-module-in-correct-location.patch
parent11be89550b55b77707a062d7468fa5767b84acf1 (diff)
Refresh patches.
Diffstat (limited to 'debian/patches/0006-Install-Python-module-in-correct-location.patch')
-rw-r--r--debian/patches/0006-Install-Python-module-in-correct-location.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/patches/0006-Install-Python-module-in-correct-location.patch b/debian/patches/0006-Install-Python-module-in-correct-location.patch
index 1e4310ee..e8c23fde 100644
--- a/debian/patches/0006-Install-Python-module-in-correct-location.patch
+++ b/debian/patches/0006-Install-Python-module-in-correct-location.patch
@@ -7,15 +7,15 @@ Subject: Install Python module in correct location.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 472993b..1dd3721 100644
+index 1a2f18b..94ef78b 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -230,7 +230,7 @@ endif(CGAL_FOUND)
+@@ -243,7 +243,7 @@ if(PYTHONINTERP_FOUND)
add_custom_target(python ALL DEPENDS gudhi.so
COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
+ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} setup.py install --root=${CMAKE_SOURCE_DIR}/debian/tmp --single-version-externally-managed --install-layout=deb WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})")
- # Test examples
- if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ # Documentation generation is available through sphinx - requires all modules
+ # Make it first as sphinx test is by far the longest test which is nice when testing in parallel