summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/benchmark/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-09-17 20:58:41 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-09-17 20:58:41 +0000
commit9ded4522e4be2b018172c0563b2acf9d5cdc5b44 (patch)
treea691f1fa0817ad20f999d2437d2af9a2f70a11d8 /src/Alpha_complex/benchmark/CMakeLists.txt
parente618887f6bed9dbfc36bb6a7c6174a83bb2dd68e (diff)
Add benchmark
Safe version for Alpha complex 3d (missing part if not weighted and not periodic) Need to fix Alpha_complex_3d_unit_test git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alpha_complex_3d_module_vincent@3893 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 304c9f89826008eab67a72f3742caa8d6d80f36b
Diffstat (limited to 'src/Alpha_complex/benchmark/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/benchmark/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Alpha_complex/benchmark/CMakeLists.txt b/src/Alpha_complex/benchmark/CMakeLists.txt
new file mode 100644
index 00000000..622963dc
--- /dev/null
+++ b/src/Alpha_complex/benchmark/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(Alpha_complex_benchmark)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable(Alpha_complex_3d_benchmark Alpha_complex_3d_benchmark.cpp)
+ target_link_libraries(Alpha_complex_3d_benchmark ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Alpha_complex_3d_benchmark ${TBB_LIBRARIES})
+ endif()
+endif ()