summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/include/gudhi/Alpha_complex_3d.h
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-07-04 06:21:07 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-07-04 06:21:07 +0000
commitd5b5de5aa50c2fdc73d00bbdcf295caf44237a34 (patch)
tree1eac364fd03232ce21fd7c621599b9b17cf7710b /src/Alpha_complex/include/gudhi/Alpha_complex_3d.h
parent9b8bb34ff06b08119b8fa1e78c260886287c5a92 (diff)
Fix SimplicialComplexForAlpha (dD version)
Write SimplicialComplexForAlpha3d concept Add make_filtration_non_decreasing and prune_above_filtration mechanism for Alpha_complex_3d Write documentation for Alpha_complex_3d ( still missing the user version) Remove exact static bool from Alpha_complex_3d_options mechanism and add some comments on value_from_iterator functions Fix Alpha_complex/utilities/CMakeLists.txt warnings git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alpha_complex_3d_module_vincent@3667 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 32e15aaf98df14a43eaef4a4af00de2ec418924c
Diffstat (limited to 'src/Alpha_complex/include/gudhi/Alpha_complex_3d.h')
-rw-r--r--src/Alpha_complex/include/gudhi/Alpha_complex_3d.h29
1 files changed, 24 insertions, 5 deletions
diff --git a/src/Alpha_complex/include/gudhi/Alpha_complex_3d.h b/src/Alpha_complex/include/gudhi/Alpha_complex_3d.h
index 1d171f7d..f37c0816 100644
--- a/src/Alpha_complex/include/gudhi/Alpha_complex_3d.h
+++ b/src/Alpha_complex/include/gudhi/Alpha_complex_3d.h
@@ -56,19 +56,23 @@ namespace Gudhi {
namespace alpha_complex {
/**
- * \class Alpha_complex_3d Alpha_complex_3d.h gudhi/Alpha_complex_3d.h
+ * \class Alpha_complex_3d
* \brief Alpha complex data structure for 3d specific case.
*
* \ingroup alpha_complex
*
* \details
- * The data structure is constructing a CGAL Delaunay triangulation (for more informations on CGAL Delaunay
- * triangulation, please refer to the corresponding chapter in page http://doc.cgal.org/latest/Triangulation/) from a
- * range of points or from an OFF file (cf. Points_off_reader).
+ * The data structure is constructing a <a href="https://doc.cgal.org/latest/Alpha_shapes_3/index.html">CGAL 3D Alpha
+ * Shapes</a> from a range of points (can be read from an OFF file, cf. Points_off_reader).
+ *
+ * \tparam AlphaComplex3dOptions can be `Gudhi::alpha_complex::Alpha_shapes_3d`,
+ * `Gudhi::alpha_complex::Exact_alpha_shapes_3d`, `Gudhi::alpha_complex::Weighted_alpha_shapes_3d`,
+ * `Gudhi::alpha_complex::Periodic_alpha_shapes_3d` or `Gudhi::alpha_complex::Weighted_periodic_alpha_shapes_3d`.
*
* Please refer to \ref alpha_complex for examples.
*
- * \remark When Alpha_complex is constructed with an infinite value of alpha, the complex is a Delaunay complex.
+ * \remark When Alpha_complex_3d is constructed with an infinite value of alpha (default value), the complex is a
+ * Delaunay complex.
*
*/
template<typename AlphaComplex3dOptions>
@@ -100,6 +104,9 @@ public:
*
* @param[in] points Range of points to triangulate. Points must be in AlphaComplex3dOptions::Point_3
*
+ * @pre Available if AlphaComplex3dOptions is `Gudhi::alpha_complex::Alpha_shapes_3d` or
+ * `Gudhi::alpha_complex::Exact_alpha_shapes_3d`.
+ *
* The type InputPointRange must be a range for which std::begin and
* std::end return input iterators on a AlphaComplex3dOptions::Point_3.
*/
@@ -135,6 +142,8 @@ public:
* @param[in] points Range of points to triangulate. Points must be in AlphaComplex3dOptions::Point_3
* @param[in] weights Range of weights on points. Points must be in AlphaComplex3dOptions::Point_3
*
+ * @pre Available if AlphaComplex3dOptions is `Weighted_alpha_shapes_3d`.
+ *
* The type InputPointRange must be a range for which std::begin and
* std::end return input iterators on a AlphaComplex3dOptions::Point_3.
* The type WeightRange must be a range for which std::begin and
@@ -192,6 +201,8 @@ public:
* @param[in] y_max Iso-oriented cuboid y_max.
* @param[in] z_max Iso-oriented cuboid z_max.
*
+ * @pre Available if AlphaComplex3dOptions is `Periodic_alpha_shapes_3d`.
+ *
* The type InputPointRange must be a range for which std::begin and
* std::end return input iterators on a AlphaComplex3dOptions::Point_3.
* The type of x_min, y_min, z_min, x_max, y_max and z_max is AlphaComplex3dOptions::Alpha_shape_3::FT.
@@ -265,6 +276,8 @@ public:
* @param[in] y_max Iso-oriented cuboid y_max.
* @param[in] z_max Iso-oriented cuboid z_max.
*
+ * @pre Available if AlphaComplex3dOptions is `Weighted_periodic_alpha_shapes_3d`.
+ *
* The type InputPointRange must be a range for which std::begin and
* std::end return input iterators on a AlphaComplex3dOptions::Point_3.
* The type WeightRange must be a range for which std::begin and
@@ -461,6 +474,12 @@ public:
std::cout << "facets \t\t" << count_facets << std::endl;
std::cout << "cells \t\t" << count_cells << std::endl;
#endif // DEBUG_TRACES
+ // --------------------------------------------------------------------------------------------
+ // As Alpha value is an approximation, we have to make filtration non decreasing while increasing the dimension
+ complex.make_filtration_non_decreasing();
+ // Remove all simplices that have a filtration value greater than max_alpha_square
+ complex.prune_above_filtration(max_alpha_square);
+ // --------------------------------------------------------------------------------------------
return true;
}