summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-11-04 09:04:19 +0100
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-11-04 09:04:19 +0100
commiteb8164b76a062fe510a9281bfebfa34f66c72163 (patch)
tree3d3b8adb5c431011387c0bba637707344d0780cb /src/Alpha_complex/test/CMakeLists.txt
parent218be4f4c88f94c2c281cce16d5a9cd41fdd2fd8 (diff)
parent6811a26e8b45ba4fde5ad3268d0eb07d3070a349 (diff)
Merge branch 'master' into coxeter_integration
Diffstat (limited to 'src/Alpha_complex/test/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index f38bd096..db5d840f 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -43,3 +43,20 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
gudhi_add_boost_test(Weighted_periodic_alpha_complex_3d_test_unit)
endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 5.1.0)
+ add_executable ( Alpha_kernel_d_test_unit Alpha_kernel_d_unit_test.cpp )
+ target_link_libraries(Alpha_kernel_d_test_unit ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Alpha_kernel_d_test_unit ${TBB_LIBRARIES})
+ endif()
+ gudhi_add_boost_test(Alpha_kernel_d_test_unit)
+
+ add_executable ( Weighted_alpha_complex_test_unit Weighted_alpha_complex_unit_test.cpp )
+ target_link_libraries(Weighted_alpha_complex_test_unit ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Weighted_alpha_complex_test_unit ${TBB_LIBRARIES})
+ endif()
+ gudhi_add_boost_test(Weighted_alpha_complex_test_unit)
+
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 5.1.0) \ No newline at end of file