summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/utilities
diff options
context:
space:
mode:
authorROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-09-04 17:26:33 +0200
committerROUVREAU Vincent <vincent.rouvreau@inria.fr>2020-09-04 17:26:33 +0200
commitda3debd6896830592bc305bc688431d09539014e (patch)
tree9f0317930aef92a82c33f83d9a00958e6ab0aa98 /src/Alpha_complex/utilities
parentdb938dbd74460e7a0fd705be8628984052f71dc0 (diff)
parent6e14ef1f31e09f3875316440303450ff870d9881 (diff)
Merge branch 'master' of https://github.com/GUDHI/gudhi-devel into weighted_alpha_complex_dD
Diffstat (limited to 'src/Alpha_complex/utilities')
-rw-r--r--src/Alpha_complex/utilities/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Alpha_complex/utilities/CMakeLists.txt b/src/Alpha_complex/utilities/CMakeLists.txt
index 2ffbdde0..f0ddfc2c 100644
--- a/src/Alpha_complex/utilities/CMakeLists.txt
+++ b/src/Alpha_complex/utilities/CMakeLists.txt
@@ -27,7 +27,9 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
endif()
install(TARGETS alpha_complex_persistence DESTINATION bin)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
add_executable(alpha_complex_3d_persistence alpha_complex_3d_persistence.cpp)
target_link_libraries(alpha_complex_3d_persistence ${CGAL_LIBRARY} Boost::program_options)
if (TBB_FOUND)
@@ -75,4 +77,4 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
install(TARGETS alpha_complex_3d_persistence DESTINATION bin)
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)