summaryrefslogtreecommitdiff
path: root/src/Alpha_shapes
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-01 14:34:21 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-01 14:34:21 +0000
commit92f5b06cbbff0f053f34503afddaeeb2c29efde1 (patch)
tree8948d991fa3815dfa76f91b61bd68cea84f96046 /src/Alpha_shapes
parent27aafb2466da4c67eeb9bc55b7275141108a845b (diff)
GCovr replaces lcov - cpplint_to_cppcheckxml to be conform with xml version 2
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/xunit@529 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: e042eea0b285159f071afb0d07729e6c381f036d
Diffstat (limited to 'src/Alpha_shapes')
-rw-r--r--src/Alpha_shapes/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Alpha_shapes/test/CMakeLists.txt b/src/Alpha_shapes/test/CMakeLists.txt
index 98a935db..a820acc2 100644
--- a/src/Alpha_shapes/test/CMakeLists.txt
+++ b/src/Alpha_shapes/test/CMakeLists.txt
@@ -15,6 +15,13 @@ if(CGAL_FOUND)
include( ${EIGEN3_USE_FILE} )
include_directories (BEFORE "../../include")
+ if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -fprofile-arcs -ftest-coverage")
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -fprofile-arcs -ftest-coverage")
+ endif()
+
add_definitions(-DDEBUG_TRACES)
add_executable ( AlphaShapesUT Alpha_shapes_unit_test.cpp )
target_link_libraries(AlphaShapesUT ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})