summaryrefslogtreecommitdiff
path: root/src/Bipartite_graphs_matching/example/CMakeLists.txt
diff options
context:
space:
mode:
authorfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-02 17:11:11 +0000
committerfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-02 17:11:11 +0000
commit8068835924d52b8bbc1943f117dcda36c49d32f6 (patch)
treea4321307d20894290f9ea8ada03834bc65ec2939 /src/Bipartite_graphs_matching/example/CMakeLists.txt
parent3b5b94c90c81ae4938a89b2b4df8b1173f100ee3 (diff)
old name removed
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bottleneckDistance@1241 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 66627d6e4e4d292717d8991351a7d31062b734a8
Diffstat (limited to 'src/Bipartite_graphs_matching/example/CMakeLists.txt')
-rw-r--r--src/Bipartite_graphs_matching/example/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/src/Bipartite_graphs_matching/example/CMakeLists.txt b/src/Bipartite_graphs_matching/example/CMakeLists.txt
deleted file mode 100644
index 4e8766cc..00000000
--- a/src/Bipartite_graphs_matching/example/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-project(GUDHIBottleneckExample)
-
-# need CGAL 4.6
-# cmake -DCGAL_DIR=~/workspace/CGAL-4.6-beta1 ../../..
-if(CGAL_FOUND)
- if (NOT CGAL_VERSION VERSION_LESS 4.6.0)
- message(STATUS "CGAL version: ${CGAL_VERSION}.")
-
- include( ${CGAL_USE_FILE} )
-
- if(NOT MSVC)
- include(CheckCXXCompilerFlag)
- CHECK_CXX_COMPILER_FLAG(-std=c++11 COMPILER_SUPPORTS_CXX11)
- if(COMPILER_SUPPORTS_CXX11)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
- endif()
- endif()
- # - End of workaround
-
- find_package(Eigen3 3.1.0)
- if (EIGEN3_FOUND)
- message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
- include( ${EIGEN3_USE_FILE} )
- include_directories (BEFORE "../../include")
-
- add_executable (basic_example basic.cpp)
- #add_test(dtoffrw_tore3D ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw ${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off 3)
-
- else()
- message(WARNING "Eigen3 not found. Version 3.1.0 is required.")
- endif()
- else()
- message(WARNING "CGAL version: ${CGAL_VERSION} is too old to compile Alpha shapes feature. Version 4.6.0 is required.")
- endif ()
-endif()