summaryrefslogtreecommitdiff
path: root/src/Bottleneck/example
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-03-19 12:19:22 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-03-19 12:19:22 +0000
commit8c820ca8f9da625084f94dc9b80bb936f2c7aa8a (patch)
treeceeb3cefb54bf30a4819534bffb4a791ef1be2d3 /src/Bottleneck/example
parenta52663bd7c94c402200605062b7e70dc4575d781 (diff)
Add of bottleneck functionnality
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bottleneckDistance@492 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 68ecf70a07641fea7106a17bbbf45404747834cc
Diffstat (limited to 'src/Bottleneck/example')
-rw-r--r--src/Bottleneck/example/CMakeLists.txt5
-rw-r--r--src/Bottleneck/example/random_diagrams.cpp40
2 files changed, 45 insertions, 0 deletions
diff --git a/src/Bottleneck/example/CMakeLists.txt b/src/Bottleneck/example/CMakeLists.txt
new file mode 100644
index 00000000..2ff009c4
--- /dev/null
+++ b/src/Bottleneck/example/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHIBottleneckExample)
+
+add_executable ( RandomDiagrams random_diagrams.cpp )
+add_test(RandomDiagrams ${CMAKE_CURRENT_BINARY_DIR}/RandomDiagrams)
diff --git a/src/Bottleneck/example/random_diagrams.cpp b/src/Bottleneck/example/random_diagrams.cpp
new file mode 100644
index 00000000..71f152a6
--- /dev/null
+++ b/src/Bottleneck/example/random_diagrams.cpp
@@ -0,0 +1,40 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): Francois Godi
+ *
+ * Copyright (C) 2015 INRIA Saclay (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include "gudhi/Graph_matching.h"
+#include <iostream>
+
+using namespace Gudhi::bottleneck;
+
+int main() {
+ int n = 100;
+ std::vector< std::pair<double, double> > v1, v2;
+ for (int i = 0; i < n; i++) {
+ int a = rand() % n;
+ v1.emplace_back(a, a + rand() % (n - a));
+ int b = rand() % n;
+ v2.emplace_back(b, b + rand() % (n - b));
+ }
+ // v1 and v2 are persistence diagrams containing each 100 randoms points.
+ double b = bottleneck_distance(v1, v2, 0);
+ std::cout << b << std::endl;
+}