summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-01-20 15:33:53 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-01-20 15:33:53 +0000
commit3f451b963739a595d990be5517d386259ddb487f (patch)
tree4e6b8ccbf21c28c103effd9342f75907c89cf42a /src/Bottleneck_distance/example/CMakeLists.txt
parentad6a64ad5a4f4121410250021eda0904eb9c718c (diff)
parentcbf1a50068a2c5dea6d732d40dfc66d34460d863 (diff)
Merge last trunk modifications in qt5 branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/qt5@1976 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 7f8c5b9443bf0996347fe459fe21c42a2fed0cca
Diffstat (limited to 'src/Bottleneck_distance/example/CMakeLists.txt')
-rw-r--r--src/Bottleneck_distance/example/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Bottleneck_distance/example/CMakeLists.txt b/src/Bottleneck_distance/example/CMakeLists.txt
new file mode 100644
index 00000000..c66623e9
--- /dev/null
+++ b/src/Bottleneck_distance/example/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.6)
+project(Bottleneck_distance_examples)
+
+# requires CGAL 4.8
+# cmake -DCGAL_DIR=~/workspace/CGAL-4.8 ../../..
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ if (EIGEN3_FOUND)
+ add_executable (bottleneck_read_file_example bottleneck_read_file_example.cpp)
+ add_executable (bottleneck_basic_example bottleneck_basic_example.cpp)
+
+ add_test(bottleneck_basic_example ${CMAKE_CURRENT_BINARY_DIR}/bottleneck_basic_example)
+ endif()
+ endif ()
+endif()