summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/utilities
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-15 14:20:30 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-11-15 14:20:30 +0000
commit8428e315efa22a1b40eb996c98eff671f91a9b27 (patch)
treedc2a8813436d0decc171e6779ef4e1db8c89c212 /src/Bottleneck_distance/utilities
parent629542264458d2174ece2c18a490f63d1a231802 (diff)
Fixes according to Marc's review
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/add_utils_in_gudhi_v2@2881 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 84870193cb05cabd8c756a3bbc49083e4d739525
Diffstat (limited to 'src/Bottleneck_distance/utilities')
-rw-r--r--src/Bottleneck_distance/utilities/CMakeLists.txt11
-rw-r--r--src/Bottleneck_distance/utilities/README19
-rw-r--r--src/Bottleneck_distance/utilities/alpha_rips_persistence_bottleneck_distance.cpp190
-rw-r--r--src/Bottleneck_distance/utilities/bottleneck_read_file_example.cpp50
4 files changed, 60 insertions, 210 deletions
diff --git a/src/Bottleneck_distance/utilities/CMakeLists.txt b/src/Bottleneck_distance/utilities/CMakeLists.txt
index 634b2479..decdc789 100644
--- a/src/Bottleneck_distance/utilities/CMakeLists.txt
+++ b/src/Bottleneck_distance/utilities/CMakeLists.txt
@@ -2,16 +2,15 @@ cmake_minimum_required(VERSION 2.6)
project(Bottleneck_distance_utilities)
if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable (alpha_rips_persistence_bottleneck_distance alpha_rips_persistence_bottleneck_distance.cpp)
- target_link_libraries(alpha_rips_persistence_bottleneck_distance ${Boost_PROGRAM_OPTIONS_LIBRARY})
+ add_executable (bottleneck_read_file_example bottleneck_read_file_example.cpp)
if (TBB_FOUND)
target_link_libraries(alpha_rips_persistence_bottleneck_distance ${TBB_LIBRARIES})
endif(TBB_FOUND)
- add_test(NAME Bottleneck_distance_example_alpha_rips_persistence_bottleneck
- COMMAND $<TARGET_FILE:alpha_rips_persistence_bottleneck_distance>
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.15" "-m" "0.12" "-d" "3" "-p" "3")
+ add_test(NAME Bottleneck_read_file_example
+ COMMAND $<TARGET_FILE:bottleneck_read_file_example>
+ "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
- install(TARGETS alpha_rips_persistence_bottleneck_distance DESTINATION bin)
+ install(TARGETS bottleneck_read_file_example DESTINATION bin)
endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
diff --git a/src/Bottleneck_distance/utilities/README b/src/Bottleneck_distance/utilities/README
index 4c9b0735..cfdccf0b 100644
--- a/src/Bottleneck_distance/utilities/README
+++ b/src/Bottleneck_distance/utilities/README
@@ -1,19 +1,10 @@
# Bottleneck_distance #
-## `alpha_rips_persistence_bottleneck_distance` ##
-This program computes the persistent homology with coefficient field Z/pZ of a Rips complex defined on a set of input points. The output diagram contains one bar per line, written with the convention:
-
-`p dim b d`
-
-where `dim` is the dimension of the homological feature, `b` and `d` are respectively the birth and death of the feature, and `p` is the characteristic of the field *Z/pZ* used for homology coefficients.
+## `bottleneck_read_file_example` ##
+This program computes the Bottleneck distance between two persistence diagram files.
Usage:
-`alpha_rips_persistence_bottleneck_distance [options] <OFF input file>`
-
-Allowed options:
+`bottleneck_read_file_example <file_1.pers> <file_2.pers> [<tolerance>]`
-* `-h [ --help ]` Produce help message
-* `-r [ --max-edge-length ]` (default = inf) Maximal length of an edge for the Rips complex construction.`
-* `-d [ --cpx-dimension ]` (default = 1) Maximal dimension of the Rips complex we want to compute.`
-* `-p [ --field-charac ]` (default = 11) Characteristic p of the coefficient field Z/pZ for computing homology.
-* `-m [ --min-persistence ]` (default = 0) Minimal lifetime of homology feature to be recorded. Enter a negative value to see zero length intervals. \ No newline at end of file
+<file_1.pers> and <file_2.pers> must be in the format described [here](http://gudhi.gforge.inria.fr/doc/latest/fileformats.html#FileFormatsPers).
+<tolerance> is an error bound on the bottleneck distance (set by default to the smallest positive double value).
diff --git a/src/Bottleneck_distance/utilities/alpha_rips_persistence_bottleneck_distance.cpp b/src/Bottleneck_distance/utilities/alpha_rips_persistence_bottleneck_distance.cpp
deleted file mode 100644
index fd164b22..00000000
--- a/src/Bottleneck_distance/utilities/alpha_rips_persistence_bottleneck_distance.cpp
+++ /dev/null
@@ -1,190 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Vincent Rouvreau
- *
- * Copyright (C) 2017 INRIA
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Alpha_complex.h>
-#include <gudhi/Rips_complex.h>
-#include <gudhi/distance_functions.h>
-#include <gudhi/Simplex_tree.h>
-#include <gudhi/Persistent_cohomology.h>
-#include <gudhi/Points_off_io.h>
-#include <gudhi/Bottleneck.h>
-
-#include <CGAL/Epick_d.h>
-
-#include <boost/program_options.hpp>
-
-#include <string>
-#include <vector>
-#include <limits> // infinity
-#include <utility> // for pair
-#include <algorithm> // for transform
-
-
-// Types definition
-using Simplex_tree = Gudhi::Simplex_tree<Gudhi::Simplex_tree_options_fast_persistence>;
-using Filtration_value = Simplex_tree::Filtration_value;
-using Rips_complex = Gudhi::rips_complex::Rips_complex<Filtration_value>;
-using Field_Zp = Gudhi::persistent_cohomology::Field_Zp;
-using Persistent_cohomology = Gudhi::persistent_cohomology::Persistent_cohomology<Simplex_tree, Field_Zp >;
-using Kernel = CGAL::Epick_d< CGAL::Dynamic_dimension_tag >;
-using Point_d = Kernel::Point_d;
-using Points_off_reader = Gudhi::Points_off_reader<Point_d>;
-
-void program_options(int argc, char * argv[]
- , std::string & off_file_points
- , Filtration_value & threshold
- , int & dim_max
- , int & p
- , Filtration_value & min_persistence);
-
-static inline std::pair<double, double> compute_root_square(std::pair<double, double> input) {
- return std::make_pair(std::sqrt(input.first), std::sqrt(input.second));
-}
-
-int main(int argc, char * argv[]) {
- std::string off_file_points;
- Filtration_value threshold;
- int dim_max;
- int p;
- Filtration_value min_persistence;
-
- program_options(argc, argv, off_file_points, threshold, dim_max, p, min_persistence);
-
- Points_off_reader off_reader(off_file_points);
-
- // --------------------------------------------
- // Rips persistence
- // --------------------------------------------
- Rips_complex rips_complex(off_reader.get_point_cloud(), threshold, Gudhi::Euclidean_distance());
-
- // Construct the Rips complex in a Simplex Tree
- Simplex_tree rips_stree;
-
- rips_complex.create_complex(rips_stree, dim_max);
- std::cout << "The Rips complex contains " << rips_stree.num_simplices() << " simplices and has dimension "
- << rips_stree.dimension() << " \n";
-
- // Sort the simplices in the order of the filtration
- rips_stree.initialize_filtration();
-
- // Compute the persistence diagram of the complex
- Persistent_cohomology rips_pcoh(rips_stree);
- // initializes the coefficient field for homology
- rips_pcoh.init_coefficients(p);
- rips_pcoh.compute_persistent_cohomology(min_persistence);
-
- // rips_pcoh.output_diagram();
-
- // --------------------------------------------
- // Alpha persistence
- // --------------------------------------------
- Gudhi::alpha_complex::Alpha_complex<Kernel> alpha_complex(off_reader.get_point_cloud());
-
- Simplex_tree alpha_stree;
- alpha_complex.create_complex(alpha_stree, threshold * threshold);
- std::cout << "The Alpha complex contains " << alpha_stree.num_simplices() << " simplices and has dimension "
- << alpha_stree.dimension() << " \n";
-
- // Sort the simplices in the order of the filtration
- alpha_stree.initialize_filtration();
-
- // Compute the persistence diagram of the complex
- Persistent_cohomology alpha_pcoh(alpha_stree);
- // initializes the coefficient field for homology
- alpha_pcoh.init_coefficients(p);
- alpha_pcoh.compute_persistent_cohomology(min_persistence * min_persistence);
-
- // alpha_pcoh.output_diagram();
-
- // --------------------------------------------
- // Bottleneck distance between both persistence
- // --------------------------------------------
- double max_b_distance {};
- for (int dim = 0; dim < dim_max; dim ++) {
- std::vector< std::pair< Filtration_value , Filtration_value > > rips_intervals;
- std::vector< std::pair< Filtration_value , Filtration_value > > alpha_intervals;
- rips_intervals = rips_pcoh.intervals_in_dimension(dim);
- alpha_intervals = alpha_pcoh.intervals_in_dimension(dim);
- std::transform(alpha_intervals.begin(), alpha_intervals.end(), alpha_intervals.begin(), compute_root_square);
-
- double bottleneck_distance = Gudhi::persistence_diagram::bottleneck_distance(rips_intervals, alpha_intervals);
- std::cout << "In dimension " << dim << ", bottleneck distance = " << bottleneck_distance << std::endl;
- if (bottleneck_distance > max_b_distance)
- max_b_distance = bottleneck_distance;
- }
- std::cout << "================================================================================" << std::endl;
- std::cout << "Bottleneck distance is " << max_b_distance << std::endl;
-
- return 0;
-}
-
-void program_options(int argc, char * argv[]
- , std::string & off_file_points
- , Filtration_value & threshold
- , int & dim_max
- , int & p
- , Filtration_value & min_persistence) {
- namespace po = boost::program_options;
- po::options_description hidden("Hidden options");
- hidden.add_options()
- ("input-file", po::value<std::string>(&off_file_points),
- "Name of an OFF file containing a point set.\n");
-
- po::options_description visible("Allowed options", 100);
- visible.add_options()
- ("help,h", "produce help message")
- ("max-edge-length,r",
- po::value<Filtration_value>(&threshold)->default_value(std::numeric_limits<Filtration_value>::infinity()),
- "Maximal length of an edge for the Rips complex construction.")
- ("cpx-dimension,d", po::value<int>(&dim_max)->default_value(1),
- "Maximal dimension of the Rips complex we want to compute.")
- ("field-charac,p", po::value<int>(&p)->default_value(11),
- "Characteristic p of the coefficient field Z/pZ for computing homology.")
- ("min-persistence,m", po::value<Filtration_value>(&min_persistence),
- "Minimal lifetime of homology feature to be recorded. Default is 0. Enter a negative value to see zero length intervals");
-
- po::positional_options_description pos;
- pos.add("input-file", 1);
-
- po::options_description all;
- all.add(visible).add(hidden);
-
- po::variables_map vm;
- po::store(po::command_line_parser(argc, argv).
- options(all).positional(pos).run(), vm);
- po::notify(vm);
-
- if (vm.count("help") || !vm.count("input-file")) {
- std::cout << std::endl;
- std::cout << "Compute the persistent homology with coefficient field Z/pZ \n";
- std::cout << "of a Rips complex defined on a set of input points.\n \n";
- std::cout << "The output diagram contains one bar per line, written with the convention: \n";
- std::cout << " p dim b d \n";
- std::cout << "where dim is the dimension of the homological feature,\n";
- std::cout << "b and d are respectively the birth and death of the feature and \n";
- std::cout << "p is the characteristic of the field Z/pZ used for homology coefficients." << std::endl << std::endl;
-
- std::cout << "Usage: " << argv[0] << " [options] input-file" << std::endl << std::endl;
- std::cout << visible << std::endl;
- std::abort();
- }
-}
diff --git a/src/Bottleneck_distance/utilities/bottleneck_read_file_example.cpp b/src/Bottleneck_distance/utilities/bottleneck_read_file_example.cpp
new file mode 100644
index 00000000..9dd52b31
--- /dev/null
+++ b/src/Bottleneck_distance/utilities/bottleneck_read_file_example.cpp
@@ -0,0 +1,50 @@
+/* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Authors: Francois Godi, small modifications by Pawel Dlotko
+ *
+ * Copyright (C) 2015 INRIA
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <gudhi/Bottleneck.h>
+#include <gudhi/reader_utils.h>
+#include <iostream>
+#include <vector>
+#include <utility> // for pair
+#include <string>
+#include <limits> // for numeric_limits
+
+int main(int argc, char** argv) {
+ if (argc < 3) {
+ std::cout << "To run this program please provide as an input two files with persistence diagrams. Each file" <<
+ " should contain a birth-death pair per line. Third, optional parameter is an error bound on the bottleneck" <<
+ " distance (set by default to the smallest positive double value). If you set the error bound to 0, be" <<
+ " aware this version is exact but expensive. The program will now terminate \n";
+ return -1;
+ }
+ std::vector<std::pair<double, double>> diag1 = Gudhi::read_persistence_intervals_in_dimension(argv[1]);
+ std::vector<std::pair<double, double>> diag2 = Gudhi::read_persistence_intervals_in_dimension(argv[2]);
+
+ double tolerance = std::numeric_limits<double>::min();
+ if (argc == 4) {
+ tolerance = atof(argv[3]);
+ }
+ double b = Gudhi::persistence_diagram::bottleneck_distance(diag1, diag2, tolerance);
+ std::cout << "The distance between the diagrams is : " << b << ". The tolerance is : " << tolerance << std::endl;
+
+ return 0;
+}