summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-08 12:28:04 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-04-08 12:28:04 +0000
commit8b26dea17912abc00aee9e13984ef8cbfe076b0f (patch)
tree420adf59e7d1d133c3f8838ca9c82525a57df6d8 /src/CMakeLists.txt
parent0ca1fbeb35a9a681320186f63a7cf26256ebf05a (diff)
parent635eda52786951558d820b06bb18b9f6d54dc89a (diff)
Merge of Alpha complex feature
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1108 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 05bfd7eb76782dd6e5cab03a746cac4aeacb91de
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 00bdf800..f5dccbc1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -64,16 +64,24 @@ else()
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+ if (DEBUG_TRACES)
+ message(STATUS "DEBUG_TRACES are activated")
+ # For programs to be more verbose
+ add_definitions(-DDEBUG_TRACES)
+ endif()
+
#---------------------------------------------------------------------------------------
# Gudhi compilation part
include_directories(include)
+ add_subdirectory(example/common)
add_subdirectory(example/Simplex_tree)
add_subdirectory(example/Persistent_cohomology)
add_subdirectory(example/Skeleton_blocker)
add_subdirectory(example/Contraction)
add_subdirectory(example/Bitmap_cubical_complex)
add_subdirectory(example/Witness_complex)
+ add_subdirectory(example/Alpha_complex)
# data points generator
add_subdirectory(data/points/generator)