summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-11-06 14:27:18 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-11-06 14:27:18 +0000
commit606115b399b010b8ebfbf13f6a8ca2b1c1bf17cd (patch)
treef13206921b7b77ca3d2cc66c4ed612300bdaebd8 /src/CMakeLists.txt
parentdd2a15d1a8d2607848527513210330baebce9e8e (diff)
parent72f647ad4b802d08072925a374324e7ace4b2c4d (diff)
Merge last trunk modifications
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/bitmap@889 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: d90cb012ff7f3a9070ea19e3c6651cc455bebdad
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt48
1 files changed, 40 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 576ba353..a66d90b6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,11 +1,14 @@
cmake_minimum_required(VERSION 2.6)
project(GUDHI)
+include("CMakeGUDHIVersion.txt")
+
+enable_testing()
+
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules/")
find_package(Boost REQUIRED COMPONENTS system filesystem program_options chrono timer REQUIRED)
-
if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")
endif()
@@ -35,21 +38,50 @@ else()
add_definitions(-DBOOST_ALL_NO_LIB)
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
- LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
- include_directories(include/)
-
+ LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+
+ #---------------------------------------------------------------------------------------
+ # Gudhi compilation part
+ include_directories(include)
+
add_subdirectory(example/Simplex_tree)
add_subdirectory(example/Persistent_cohomology)
add_subdirectory(example/Skeleton_blocker)
add_subdirectory(example/Contraction)
- add_subdirectory(example/Hasse_complex)
- add_subdirectory(example/Bottleneck)
add_subdirectory(example/Bitmap_cubical_complex)
+ # data points generator
+ add_subdirectory(data/points/generator)
+
+ # Please let GudhUI in last compilation position as QT is known to modify CMAKE_CXX_FLAGS
# GudhUI
add_subdirectory(GudhUI)
+ #---------------------------------------------------------------------------------------
- # data points generator
- add_subdirectory(data/points/generator)
+ #---------------------------------------------------------------------------------------
+ # GUDHIConfig.cmake
+ # Export the package for use from the build-tree
+ # (this registers the build-tree with a global CMake-registry)
+ export(PACKAGE GUDHI)
+
+ # Create the GUDHIConfig.cmake and GUDHIConfigVersion files
+ set(CONF_INCLUDE_DIRS "${PROJECT_SOURCE_DIR}/include")
+ configure_file(GUDHIConfig.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake" @ONLY)
+ configure_file(GUDHIConfigVersion.cmake.in "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake" @ONLY)
+
+ #---------------------------------------------------------------------------------------
+
+ #---------------------------------------------------------------------------------------
+ # Gudhi installation part
+
+ # Install the GUDHIConfig.cmake and GUDHIConfigVersion.cmake
+ install(FILES
+ "${PROJECT_BINARY_DIR}/GUDHIConfig.cmake"
+ "${PROJECT_BINARY_DIR}/GUDHIConfigVersion.cmake"
+ DESTINATION share/gudhi)
+
+ # install the include file on "make install"
+ install(DIRECTORY include/gudhi DESTINATION include)
+ #---------------------------------------------------------------------------------------
endif()