summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-23 14:42:02 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-23 14:42:02 +0000
commit86ed4085d26398aed26dfd9c365f8f3ee187c92e (patch)
treef49b0ac3108bacbbb87df82f0fa161b0cb1230e8 /src/CMakeLists.txt
parent75a9dfbec0db666b566278f17313297dc18619d4 (diff)
parentfb1c4cd4e98f979e7aa5042fb16da1c3884efe7f (diff)
Add of Hasse complex example compilation. Insert_simplex_with_subfaces must increment number of simplices on each insertion
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@470 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 325d24d0919e216e3b2d816521749e406f0a8f98
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 63a70496..b67ab2f8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,13 +28,14 @@ find_package(CGAL)
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
else()
- INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
- LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
- include_directories(include/)
-
- add_subdirectory(example/Simplex_tree)
- add_subdirectory(example/Persistent_cohomology)
- add_subdirectory(example/Skeleton_blocker)
- add_subdirectory(example/Contraction)
+ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+ LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
+ include_directories(include/)
+ add_subdirectory(example/Simplex_tree)
+ add_subdirectory(example/Persistent_cohomology)
+ add_subdirectory(example/Skeleton_blocker)
+ add_subdirectory(example/Contraction)
+ add_subdirectory(example/Hasse_complex)
+
endif()