summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-14 11:15:41 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-14 11:15:41 +0000
commitc0ae9d5915f52269ba387f037024d222d91b6bdd (patch)
tree487d15ee626f04759c6ef82305244541f71f9758 /src/CMakeLists.txt
parent6af3c873fadc3eae10aa964dd0105ef095201911 (diff)
parentf0e5330a88f9e89a887769ab79f6db6dd4e1c35a (diff)
Merged trunc to branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1867 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 20d5120a0702522b632008bfc6a5257c70c849d1
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3a831814..e26b2d25 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,7 +12,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules/")
find_package(Boost REQUIRED COMPONENTS system filesystem program_options chrono timer date_time REQUIRED)
if(NOT Boost_FOUND)
- message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
+ message(FATAL_ERROR "NOTICE: This program requires Boost and will not be compiled.")
else()
# For "make doxygen"
@@ -47,6 +47,10 @@ else()
if(CGAL_FOUND)
message(STATUS "CGAL version: ${CGAL_VERSION}.")
include( ${CGAL_USE_FILE} )
+
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ include_directories(BEFORE "include/gudhi_patches")
+ endif()
endif()
if(MSVC)
@@ -110,6 +114,7 @@ else()
add_subdirectory(example/Alpha_complex)
add_subdirectory(example/Spatial_searching)
add_subdirectory(example/Subsampling)
+ add_subdirectory(example/Tangential_complex)
# data points generator
add_subdirectory(data/points/generator)