summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorglisse <glisse@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-24 09:37:01 +0000
committerglisse <glisse@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-04-24 09:37:01 +0000
commitc739b2dc9916bce098560b255e2dd48c94cca83f (patch)
treef9b2d54b544d32252b1a032b25a01550da5916c6 /src/CMakeLists.txt
parent691f6d886703271f14f966cb5120462667fb3a6a (diff)
We shouldn't mess with flags in the release version of CMakeLists.txt (the one at the root if free for any abuse though).
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@570 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 93b1fdf641fa19010f6dbeca755fffd87ee7d12a
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 057b0c4f..55aa8a65 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,9 +12,7 @@ endif()
if(MSVC)
SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2 -std=c++11 -Wall -Wpedantic -Wsign-compare")
- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -ggdb -O0")
- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
endif()
set(Boost_USE_STATIC_LIBS ON)