summaryrefslogtreecommitdiff
path: root/src/Cech_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-30 21:04:22 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-30 21:04:22 +0000
commit01cfd13aa84317debb4bf681309533b693322131 (patch)
tree178bca6c0fabe13784c1fb695a1713d722c681d9 /src/Cech_complex/test/CMakeLists.txt
parentd0aa6ea5b543c4692f6e42d12252b03d5e43a255 (diff)
parent1f1033f14cef0b5b602a23c9f35659fa0168f1b4 (diff)
Merge last trunk modifications
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/python_2.1.0_fix_vincent@3495 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 4033114216c767ad4028e3f6d4ccb5f5dfb88f78
Diffstat (limited to 'src/Cech_complex/test/CMakeLists.txt')
-rw-r--r--src/Cech_complex/test/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Cech_complex/test/CMakeLists.txt b/src/Cech_complex/test/CMakeLists.txt
new file mode 100644
index 00000000..8db51173
--- /dev/null
+++ b/src/Cech_complex/test/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.6)
+project(Cech_complex_tests)
+
+include(GUDHI_test_coverage)
+
+add_executable ( Cech_complex_test_unit test_cech_complex.cpp )
+target_link_libraries(Cech_complex_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+if (TBB_FOUND)
+ target_link_libraries(Cech_complex_test_unit ${TBB_LIBRARIES})
+endif()
+
+# Do not forget to copy test files in current binary dir
+file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+gudhi_add_coverage_test(Cech_complex_test_unit)