summaryrefslogtreecommitdiff
path: root/src/Cech_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-06-24 14:26:00 +0200
committerGitHub <noreply@github.com>2022-06-24 14:26:00 +0200
commit9fc4f5e2ba50287979fc6e56708ec469d29c968c (patch)
tree2a8da721e11f78a4b54da99c15aade8ff9583cd0 /src/Cech_complex/test/CMakeLists.txt
parentbc683d3d9985cde2a2c80952971381d7c519db0a (diff)
parentb829a198e16fbef4c0cb2698b2c723fa353aac55 (diff)
Merge pull request #519 from Hind-M/cech_optimization
Cech optimization
Diffstat (limited to 'src/Cech_complex/test/CMakeLists.txt')
-rw-r--r--src/Cech_complex/test/CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/src/Cech_complex/test/CMakeLists.txt b/src/Cech_complex/test/CMakeLists.txt
index e6a2a18f..2d736f27 100644
--- a/src/Cech_complex/test/CMakeLists.txt
+++ b/src/Cech_complex/test/CMakeLists.txt
@@ -1,11 +1,14 @@
-include(GUDHI_boost_test)
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 5.0.1)
+ include(GUDHI_boost_test)
-add_executable ( Cech_complex_test_unit test_cech_complex.cpp )
-if (TBB_FOUND)
- target_link_libraries(Cech_complex_test_unit ${TBB_LIBRARIES})
-endif()
+ add_executable ( Cech_complex_test_unit test_cech_complex.cpp )
+ if (TBB_FOUND)
+ target_link_libraries(Cech_complex_test_unit ${TBB_LIBRARIES})
+ endif()
+
+ # Do not forget to copy test files in current binary dir
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-# Do not forget to copy test files in current binary dir
-file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ gudhi_add_boost_test(Cech_complex_test_unit)
-gudhi_add_boost_test(Cech_complex_test_unit)
+endif()