summaryrefslogtreecommitdiff
path: root/src/Contraction/example
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-16 12:54:43 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-16 12:54:43 +0000
commitac259e454de216c4774d3a9465598c7c96a1a224 (patch)
tree30900d0a175ee819d9057b096adf41c40a667817 /src/Contraction/example
parentc29b7b6812538bc3e39d3c6ab3a3be2999659c34 (diff)
parent0795de54e713358b8eb43bbd4352ab802a0f128a (diff)
Merge FindTBB patch for cmake.
GMP and GMPXX are required only for multi field persistence. git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1307 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 56a66e166a07b9eb22ec0d8d05ec66bb5162da5b
Diffstat (limited to 'src/Contraction/example')
-rw-r--r--src/Contraction/example/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
index 4889b82f..00dea98d 100644
--- a/src/Contraction/example/CMakeLists.txt
+++ b/src/Contraction/example/CMakeLists.txt
@@ -9,5 +9,7 @@ target_link_libraries(RipsContraction ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBR
target_link_libraries(GarlandHeckbert ${Boost_TIMER_LIBRARY} ${Boost_SYSTEM_LIBRARY})
-add_test(RipsContraction.sphere.0.2 ${CMAKE_CURRENT_BINARY_DIR}/RipsContraction ${CMAKE_SOURCE_DIR}/data/points/sphere3D_2646.off 0.2)
-add_test(RipsContraction.S0310000 ${CMAKE_CURRENT_BINARY_DIR}/RipsContraction ${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off 0.3)
+add_test(RipsContraction.tore3D.0.2 ${CMAKE_CURRENT_BINARY_DIR}/RipsContraction ${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off 0.2)
+# TODO(DS) : These tests are too long under Windows
+#add_test(RipsContraction.sphere.0.2 ${CMAKE_CURRENT_BINARY_DIR}/RipsContraction ${CMAKE_SOURCE_DIR}/data/points/sphere3D_2646.off 0.2)
+#add_test(RipsContraction.S0310000 ${CMAKE_CURRENT_BINARY_DIR}/RipsContraction ${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off 0.3)