summaryrefslogtreecommitdiff
path: root/src/Gudhi_stat/utilities/persistence_landscapes
diff options
context:
space:
mode:
authorpdlotko <pdlotko@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-31 13:22:29 +0000
committerpdlotko <pdlotko@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-03-31 13:22:29 +0000
commit318c309206f1cffcc17c9333bb6ac9e2f90b7610 (patch)
tree014b65139bf0d0ad9dc447116e9721bf9ba02a78 /src/Gudhi_stat/utilities/persistence_landscapes
parent084dc68706f1c1866d279dc75b6de92e81885844 (diff)
solved problem with cmake.
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/gudhi_stat@2294 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 34fc791c80d9e66ab18e992f73bbf3252b3d5e1e
Diffstat (limited to 'src/Gudhi_stat/utilities/persistence_landscapes')
-rw-r--r--src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt b/src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt
new file mode 100644
index 00000000..9caf73f6
--- /dev/null
+++ b/src/Gudhi_stat/utilities/persistence_landscapes/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.6)
+project(GUDHI_STAT)
+
+
+
+#persitence landscapes
+add_executable ( average_landscapes average_landscapes.cpp )
+target_link_libraries(average_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( create_landscapes create_landscapes.cpp )
+target_link_libraries(create_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( plot_landscapes plot_landscapes.cpp )
+target_link_libraries(plot_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_distance_of_landscapes compute_distance_of_landscapes.cpp )
+target_link_libraries(compute_distance_of_landscapes ${Boost_SYSTEM_LIBRARY})
+
+add_executable ( compute_scalar_product_of_landscapes compute_scalar_product_of_landscapes.cpp )
+target_link_libraries(compute_scalar_product_of_landscapes ${Boost_SYSTEM_LIBRARY})
+