summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2022-11-25 15:15:56 +0100
committerGitHub <noreply@github.com>2022-11-25 15:15:56 +0100
commit29cefe8ff7840903fc5850c73300e9f641f0fcf8 (patch)
treeaff80e6c553bc3be6fa153870431c9042d5f6a69 /src/Nerve_GIC/test/CMakeLists.txt
parent26c0058813d7dba60a9d4af8db131b17f3f67708 (diff)
parent46f4ef780df47e977e9acd95436bded4f5a69ada (diff)
Merge pull request #737 from mglisse/cover-hera
Fall back to Hera's bottleneck in Nerve_GIC
Diffstat (limited to 'src/Nerve_GIC/test/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/test/CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/src/Nerve_GIC/test/CMakeLists.txt b/src/Nerve_GIC/test/CMakeLists.txt
index 567bf43f..e012a178 100644
--- a/src/Nerve_GIC/test/CMakeLists.txt
+++ b/src/Nerve_GIC/test/CMakeLists.txt
@@ -1,15 +1,12 @@
project(Graph_induced_complex_tests)
-if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- include(GUDHI_boost_test)
+include(GUDHI_boost_test)
- add_executable ( Nerve_GIC_test_unit test_GIC.cpp )
- if (TBB_FOUND)
- target_link_libraries(Nerve_GIC_test_unit ${TBB_LIBRARIES})
- endif()
+add_executable ( Nerve_GIC_test_unit test_GIC.cpp )
+if (TBB_FOUND)
+ target_link_libraries(Nerve_GIC_test_unit ${TBB_LIBRARIES})
+endif()
- file(COPY data DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+file(COPY data DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- gudhi_add_boost_test(Nerve_GIC_test_unit)
-
-endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+gudhi_add_boost_test(Nerve_GIC_test_unit)