summaryrefslogtreecommitdiff
path: root/src/Nerve_GIC/utilities/CMakeLists.txt
diff options
context:
space:
mode:
authormcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-25 09:27:36 +0000
committermcarrier <mcarrier@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2018-05-25 09:27:36 +0000
commit52b0f4082174888c190a005fd55232e3c38b99d4 (patch)
treea38ff0166e42bafcc81f00f6f0e9e48d2ce0b29a /src/Nerve_GIC/utilities/CMakeLists.txt
parent78335c71e46bd3b77d1595edef63cedbe6cf006c (diff)
parent979de853d97225b2b5466ec0a896a06dd08325e9 (diff)
small modif to avoid assert on compute_PD()
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/Nerve_GIC@3459 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: b0e73b4e1e77743419b06d142467ebfceacf83cf
Diffstat (limited to 'src/Nerve_GIC/utilities/CMakeLists.txt')
-rw-r--r--src/Nerve_GIC/utilities/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
new file mode 100644
index 00000000..7a838a8c
--- /dev/null
+++ b/src/Nerve_GIC/utilities/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 2.6)
+project(Nerve_GIC_examples)
+
+if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ add_executable ( Nerve Nerve.cpp )
+ add_executable ( VoronoiGIC VoronoiGIC.cpp )
+
+ if (TBB_FOUND)
+ target_link_libraries(Nerve ${TBB_LIBRARIES})
+ target_link_libraries(VoronoiGIC ${TBB_LIBRARIES})
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+ "human.off" "2" "10" "0.3")
+
+ add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+ "human.off" "100")
+
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+ install(FILES KeplerMapperVisuFromTxtFile.py km.py km.py.COPYRIGHT DESTINATION bin)
+
+endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)