summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-05-30 20:18:38 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-05-30 20:18:38 +0000
commit380424f897b4e61855b82edc939e696075faede3 (patch)
treea3c046c9a3aa1f46220c3484bab6370bf6ab6366 /src/Persistent_cohomology/example/CMakeLists.txt
parent07b4360422ddeac4a7f577cc61eb368e1c7237d7 (diff)
parentca93a90b895e74cc6bdbeed9273e8cb5de195fc9 (diff)
get_persistece branch merge
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@1222 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: bd541b18e29cf7b21524e526e3aefcb363dbaa2b
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index 1f32da17..186a6c33 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -74,12 +74,17 @@ if(GMPXX_FOUND AND GMP_FOUND)
add_executable(periodic_alpha_complex_3d_persistence periodic_alpha_complex_3d_persistence.cpp)
target_link_libraries(periodic_alpha_complex_3d_persistence ${Boost_SYSTEM_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES} ${CGAL_LIBRARY})
+ add_executable(custom_persistence_sort custom_persistence_sort.cpp)
+ target_link_libraries(custom_persistence_sort ${Boost_SYSTEM_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES} ${CGAL_LIBRARY})
+
if (TBB_FOUND)
target_link_libraries(alpha_complex_persistence ${TBB_RELEASE_LIBRARY})
target_link_libraries(periodic_alpha_complex_3d_persistence ${TBB_RELEASE_LIBRARY})
+ target_link_libraries(custom_persistence_sort ${TBB_RELEASE_LIBRARY})
endif()
add_test(alpha_complex_persistence_2_0_45 ${CMAKE_CURRENT_BINARY_DIR}/alpha_complex_persistence ${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off -m 0.45 -p 2)
add_test(periodic_alpha_complex_3d_persistence_2_0 ${CMAKE_CURRENT_BINARY_DIR}/periodic_alpha_complex_3d_persistence ${CMAKE_SOURCE_DIR}/data/points/grid_10_10_10_in_0_1.off 2 0)
+ add_test(custom_persistence_sort ${CMAKE_CURRENT_BINARY_DIR}/custom_persistence_sort)
else()
message(WARNING "Eigen3 not found. Version 3.1.0 is required for Alpha shapes feature.")