summaryrefslogtreecommitdiff
path: root/src/Rips_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2019-12-12 17:17:18 +0100
committerGitHub <noreply@github.com>2019-12-12 17:17:18 +0100
commit2607200636eb01e4df5735ec311d3a69db5ed589 (patch)
tree0607f688a06e133a75addfd5d02d6bd5941339e3 /src/Rips_complex/test/CMakeLists.txt
parent5a5a534b840216719fb3f9cb819d1306ca7ed196 (diff)
parentb884a620824a9d707cec82c9dddf7ab236263b95 (diff)
Merge pull request #174 from VincentRouvreau/ctest_shall_output_failures
Fix #168 - Ctest shall output failures
Diffstat (limited to 'src/Rips_complex/test/CMakeLists.txt')
-rw-r--r--src/Rips_complex/test/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Rips_complex/test/CMakeLists.txt b/src/Rips_complex/test/CMakeLists.txt
index 745d953c..b359584e 100644
--- a/src/Rips_complex/test/CMakeLists.txt
+++ b/src/Rips_complex/test/CMakeLists.txt
@@ -1,9 +1,8 @@
project(Rips_complex_tests)
-include(GUDHI_test_coverage)
+include(GUDHI_boost_test)
add_executable ( Rips_complex_test_unit test_rips_complex.cpp )
-target_link_libraries(Rips_complex_test_unit ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Rips_complex_test_unit ${TBB_LIBRARIES})
endif()
@@ -12,4 +11,4 @@ endif()
file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
file(COPY "${CMAKE_SOURCE_DIR}/data/distance_matrix/full_square_distance_matrix.csv" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-gudhi_add_coverage_test(Rips_complex_test_unit)
+gudhi_add_boost_test(Rips_complex_test_unit)