summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-16 14:38:36 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2014-12-16 14:38:36 +0000
commite6078c1e4c7561f790afc653269cd3deca4c2350 (patch)
treee55ed929e8ad4d7c2be0e7bd8999878df3485d7c /src/Simplex_tree/example/CMakeLists.txt
parent54c6bc50795f53ff1a1227c098f0d4fe84a8d885 (diff)
parent8e83a86b147987cc256812aff78335ac8a26c36e (diff)
Merge of cpplint branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@357 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 8b6af51684401f4c45c953142aae90d6f45e6778
Diffstat (limited to 'src/Simplex_tree/example/CMakeLists.txt')
-rw-r--r--src/Simplex_tree/example/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
index 6a392d3b..ac145df5 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -1,15 +1,14 @@
cmake_minimum_required(VERSION 2.6)
project(GUDHISimplexTreeFromFile)
-# NEED TO FIND BOOST NEEDED COMPONENTS TO LINK WITH
-find_package(Boost 1.45.0 COMPONENTS system thread)
-message("Boost_lib = ${Boost_LIBRARIES}")
-
add_executable ( simplex_tree_from_file simplex_tree_from_file.cpp )
-target_link_libraries(simplex_tree_from_file ${Boost_LIBRARIES})
-
+target_link_libraries(simplex_tree_from_file ${Boost_SYSTEM_LIBRARY})
+add_test(simplex_tree_from_file_2 ${CMAKE_CURRENT_BINARY_DIR}/simplex_tree_from_file ${CMAKE_SOURCE_DIR}/data/points/Klein_bottle_complex.txt 2)
+add_test(simplex_tree_from_file_3 ${CMAKE_CURRENT_BINARY_DIR}/simplex_tree_from_file ${CMAKE_SOURCE_DIR}/data/points/Klein_bottle_complex.txt 3)
+
add_executable ( simple_simplex_tree simple_simplex_tree.cpp )
-target_link_libraries(simple_simplex_tree ${Boost_LIBRARIES})
+target_link_libraries(simple_simplex_tree ${Boost_SYSTEM_LIBRARY})
+add_test(simple_simplex_tree ${CMAKE_CURRENT_BINARY_DIR}/simple_simplex_tree)
# An example with Simplex-tree using CGAL alpha_shapes_3
if(GMPXX_FOUND AND GMP_FOUND AND CGAL_FOUND)
@@ -18,5 +17,6 @@ if(GMPXX_FOUND AND GMP_FOUND AND CGAL_FOUND)
message("GMP_LIBRARIES = ${GMP_LIBRARIES}")
add_executable ( simplex_tree_from_alpha_shapes_3 simplex_tree_from_alpha_shapes_3.cpp )
- target_link_libraries(simplex_tree_from_alpha_shapes_3 ${Boost_LIBRARIES} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES} ${CGAL_LIBRARY})
+ target_link_libraries(simplex_tree_from_alpha_shapes_3 ${Boost_SYSTEM_LIBRARY} ${GMPXX_LIBRARIES} ${GMP_LIBRARIES} ${CGAL_LIBRARY})
+ add_test(simplex_tree_from_alpha_shapes_3 ${CMAKE_CURRENT_BINARY_DIR}/simplex_tree_from_alpha_shapes_3 ${CMAKE_SOURCE_DIR}/data/points/bunny_5000)
endif()