summaryrefslogtreecommitdiff
path: root/src/Simplex_tree/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2020-03-13 16:00:19 +0100
committerGitHub <noreply@github.com>2020-03-13 16:00:19 +0100
commit05b409f60132a73e47f6f58ba80a6343b5bdb1a6 (patch)
tree62bddcfaa01b5a988d316b9f9bbc04161105a8b5 /src/Simplex_tree/test/CMakeLists.txt
parent5e7e9ed155bb529127dd605bd42fb2de51fb8d32 (diff)
parent19ea0c10f283188282a78ebebf4c1a51f2f40040 (diff)
Merge pull request #237 from VincentRouvreau/handle_nan_in_simplex_tree_make_filtration_non_decreasing
Fix #172 and add a proper comment on the modification
Diffstat (limited to 'src/Simplex_tree/test/CMakeLists.txt')
-rw-r--r--src/Simplex_tree/test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Simplex_tree/test/CMakeLists.txt b/src/Simplex_tree/test/CMakeLists.txt
index 8b9163f5..cf2b0153 100644
--- a/src/Simplex_tree/test/CMakeLists.txt
+++ b/src/Simplex_tree/test/CMakeLists.txt
@@ -28,3 +28,9 @@ if (TBB_FOUND)
target_link_libraries(Simplex_tree_ctor_and_move_test_unit ${TBB_LIBRARIES})
endif()
gudhi_add_boost_test(Simplex_tree_ctor_and_move_test_unit)
+
+add_executable ( Simplex_tree_make_filtration_non_decreasing_test_unit simplex_tree_make_filtration_non_decreasing_unit_test.cpp )
+if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_make_filtration_non_decreasing_test_unit ${TBB_LIBRARIES})
+endif()
+gudhi_add_boost_test(Simplex_tree_make_filtration_non_decreasing_test_unit)