summaryrefslogtreecommitdiff
path: root/src/Skeleton_blocker/test
diff options
context:
space:
mode:
authorsalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-10 17:03:43 +0000
committersalinasd <salinasd@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-02-10 17:03:43 +0000
commitdef05e2da637a43c02e439af8faaf789214395cd (patch)
treeb2839ae762693a2a09c4876c976772332fc1342a /src/Skeleton_blocker/test
parente50f918673baf48d35c2e2ffa7bfc0e23206612f (diff)
skbl correction bug constructor + contraction add garland heckbert example
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/trunk@466 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 1789e903625df3c4e7c689fa4888bebd86e616eb
Diffstat (limited to 'src/Skeleton_blocker/test')
-rw-r--r--src/Skeleton_blocker/test/CMakeLists.txt3
-rw-r--r--src/Skeleton_blocker/test/TestGeometricComplex.cpp85
-rw-r--r--src/Skeleton_blocker/test/test.off10
-rw-r--r--src/Skeleton_blocker/test/test2.off15
4 files changed, 113 insertions, 0 deletions
diff --git a/src/Skeleton_blocker/test/CMakeLists.txt b/src/Skeleton_blocker/test/CMakeLists.txt
index d70b5d7f..c69bfec7 100644
--- a/src/Skeleton_blocker/test/CMakeLists.txt
+++ b/src/Skeleton_blocker/test/CMakeLists.txt
@@ -11,9 +11,12 @@ endif()
add_executable(TestSkeletonBlockerComplex TestSkeletonBlockerComplex.cpp)
add_executable(TestSimplifiable TestSimplifiable.cpp)
+add_executable(TestGeometricComplex TestGeometricComplex.cpp)
add_test(TestSkeletonBlockerComplex ${CMAKE_CURRENT_BINARY_DIR}/TestSkeletonBlockerComplex)
add_test(TestSimplifiable ${CMAKE_CURRENT_BINARY_DIR}/TestSimplifiable)
+add_test(TestGeometricComplex ${CMAKE_CURRENT_BINARY_DIR}/TestGeometricComplex)
+
if (LCOV_PATH)
# Lcov code coverage of unitary test
diff --git a/src/Skeleton_blocker/test/TestGeometricComplex.cpp b/src/Skeleton_blocker/test/TestGeometricComplex.cpp
new file mode 100644
index 00000000..1a81b7f7
--- /dev/null
+++ b/src/Skeleton_blocker/test/TestGeometricComplex.cpp
@@ -0,0 +1,85 @@
+ /* This file is part of the Gudhi Library. The Gudhi library
+ * (Geometric Understanding in Higher Dimensions) is a generic C++
+ * library for computational topology.
+ *
+ * Author(s): David Salinas
+ *
+ * Copyright (C) 2014 INRIA Sophia Antipolis-Mediterranee (France)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string>
+#include <fstream>
+#include <sstream>
+#include "gudhi/Test.h"
+#include "gudhi/Skeleton_blocker.h"
+
+
+using namespace std;
+using namespace Gudhi;
+using namespace skbl;
+
+struct Geometry_trait{
+ typedef std::vector<double> Point;
+};
+
+typedef Geometry_trait::Point Point;
+typedef Skeleton_blocker_simple_geometric_traits<Geometry_trait> Complex_geometric_traits;
+typedef Skeleton_blocker_geometric_complex< Complex_geometric_traits > Complex;
+
+
+
+bool test_constructor1(){
+ Complex complex;
+ Skeleton_blocker_off_reader<Complex> off_reader("test2.off",complex);
+ if(!off_reader.is_valid()){
+ std::cerr << "Unable to read file"<<std::endl;
+ return false;
+ }
+
+
+ std::cout << "complex has "<<
+ complex.num_vertices()<<" vertices, "<<
+ complex.num_blockers()<<" blockers, "<<
+ complex.num_edges()<<" edges and" <<
+ complex.num_triangles()<<" triangles.";
+
+ if(complex.num_vertices()!=7 || complex.num_edges()!=12 || complex.num_triangles() !=6)
+ return false;
+
+ Skeleton_blocker_off_writer<Complex> off_writer("tmp.off",complex);
+ Complex same;
+ Skeleton_blocker_off_reader<Complex> off_reader2("tmp.off",same);
+
+ std::cout<<"\ncomplex:"<<complex.to_string()<<endl;
+ std::cout<<"\nsame:"<<same.to_string()<<endl;
+
+ return (complex==same);
+}
+
+
+
+int main (int argc, char *argv[])
+{
+ Tests tests_geometric_complex;
+ tests_geometric_complex.add("Test constructor 1",test_constructor1);
+
+ if(tests_geometric_complex.run())
+ return EXIT_SUCCESS;
+ else
+ return EXIT_FAILURE;
+}
diff --git a/src/Skeleton_blocker/test/test.off b/src/Skeleton_blocker/test/test.off
new file mode 100644
index 00000000..61ef2d2b
--- /dev/null
+++ b/src/Skeleton_blocker/test/test.off
@@ -0,0 +1,10 @@
+OFF
+4 4 0
+0 0 0
+1 0 0
+0 1 0
+.5 .5 1
+3 0 1 2
+3 0 1 3
+3 0 2 3
+3 1 2 3
diff --git a/src/Skeleton_blocker/test/test2.off b/src/Skeleton_blocker/test/test2.off
new file mode 100644
index 00000000..b12ce572
--- /dev/null
+++ b/src/Skeleton_blocker/test/test2.off
@@ -0,0 +1,15 @@
+OFF
+7 6 0
+-1.5 2 0
+0 2 0
+1.5 2 0
+0 1.5 0
+-1 1 0
+1 1 0
+0 0 0
+3 0 1 4
+3 1 3 4
+3 1 3 5
+3 1 2 5
+3 3 4 5
+3 4 5 6