summaryrefslogtreecommitdiff
path: root/src/Spatial_searching/test/CMakeLists.txt
diff options
context:
space:
mode:
authorcjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 15:16:13 +0000
committercjamin <cjamin@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-06-21 15:16:13 +0000
commit4ef423a7a1140f1fe1a2ce1f1bbee03990638be1 (patch)
tree0fbb1125f21aece94484faf14c3cf99603dc7456 /src/Spatial_searching/test/CMakeLists.txt
parent091796c9be3ac7ddaa96bacc71842a2808da14e4 (diff)
Add spatial searching test
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1327 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: ec003d65063981af9c6fa0dce7324d1fa879d57a
Diffstat (limited to 'src/Spatial_searching/test/CMakeLists.txt')
-rw-r--r--src/Spatial_searching/test/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Spatial_searching/test/CMakeLists.txt b/src/Spatial_searching/test/CMakeLists.txt
new file mode 100644
index 00000000..297b6749
--- /dev/null
+++ b/src/Spatial_searching/test/CMakeLists.txt
@@ -0,0 +1,27 @@
+cmake_minimum_required(VERSION 2.6)
+project(Spatial_searching_tests)
+
+if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+endif()
+if (GPROF_PATH)
+ # for gprof to make coverage reports - Jenkins
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
+endif()
+
+if(CGAL_FOUND)
+ find_package(Eigen3 3.1.0)
+ if (EIGEN3_FOUND)
+ message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
+ include( ${EIGEN3_USE_FILE} )
+ include_directories (BEFORE "../../include")
+
+ add_executable( Spatial_searching_test_Spatial_tree_data_structure test_Spatial_tree_data_structure.cpp )
+ target_link_libraries(Spatial_searching_test_Spatial_tree_data_structure ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ else()
+ message(WARNING "Eigen3 not found. Version 3.1.0 is required for the Spatial_searching tests.")
+ endif()
+else()
+ message(WARNING "CGAL not found. It is required for the Spatial_searching tests.")
+endif()