summaryrefslogtreecommitdiff
path: root/src/Tangential_complex/example/CMakeLists.txt
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-11-30 21:39:44 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-11-30 21:39:44 +0000
commit004dac98fde448065a1697ea696a67153ccdb77e (patch)
tree17ec387720eda84de38966b116d13386b2b69177 /src/Tangential_complex/example/CMakeLists.txt
parent4ffc2d3d01006aebc0f5bdaa1b06dd33ffa8809e (diff)
Add tan_test for test purpose
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/tangential_test@1807 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 85200e0b013cc119aead9556e97db877b3421064
Diffstat (limited to 'src/Tangential_complex/example/CMakeLists.txt')
-rw-r--r--src/Tangential_complex/example/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Tangential_complex/example/CMakeLists.txt b/src/Tangential_complex/example/CMakeLists.txt
index a75ccd5b..76ba0a32 100644
--- a/src/Tangential_complex/example/CMakeLists.txt
+++ b/src/Tangential_complex/example/CMakeLists.txt
@@ -8,9 +8,12 @@ if(CGAL_FOUND)
target_link_libraries(Tangential_complex_example_basic ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
add_executable( Tangential_complex_example_with_perturb example_with_perturb.cpp )
target_link_libraries(Tangential_complex_example_with_perturb ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
+ add_executable( tan_test tan_test.cpp )
+ target_link_libraries(tan_test ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Tangential_complex_example_basic ${TBB_LIBRARIES})
target_link_libraries(Tangential_complex_example_with_perturb ${TBB_LIBRARIES})
+ target_link_libraries(tan_test ${TBB_LIBRARIES})
endif(TBB_FOUND)
add_test(Tangential_complex_example_basic
@@ -18,6 +21,9 @@ if(CGAL_FOUND)
add_test(Tangential_complex_example_with_perturb
${CMAKE_CURRENT_BINARY_DIR}/Tangential_complex_example_with_perturb)
+
+ add_test(tan_test
+ ${CMAKE_CURRENT_BINARY_DIR}/tan_test)
endif(EIGEN3_FOUND)
endif(NOT CGAL_VERSION VERSION_LESS 4.8.0)
endif(CGAL_FOUND)