summaryrefslogtreecommitdiff
path: root/src/Tangential_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
authorskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-14 11:15:41 +0000
committerskachano <skachano@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2016-12-14 11:15:41 +0000
commitc0ae9d5915f52269ba387f037024d222d91b6bdd (patch)
tree487d15ee626f04759c6ef82305244541f71f9758 /src/Tangential_complex/test/CMakeLists.txt
parent6af3c873fadc3eae10aa964dd0105ef095201911 (diff)
parentf0e5330a88f9e89a887769ab79f6db6dd4e1c35a (diff)
Merged trunc to branch
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/subsampling_and_spatialsearching@1867 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 20d5120a0702522b632008bfc6a5257c70c849d1
Diffstat (limited to 'src/Tangential_complex/test/CMakeLists.txt')
-rw-r--r--src/Tangential_complex/test/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/Tangential_complex/test/CMakeLists.txt b/src/Tangential_complex/test/CMakeLists.txt
new file mode 100644
index 00000000..075028c8
--- /dev/null
+++ b/src/Tangential_complex/test/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required(VERSION 2.6)
+project(Tangential_complex_tests)
+
+if (GCOVR_PATH)
+ # for gcovr to make coverage reports - Corbera Jenkins plugin
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
+endif()
+if (GPROF_PATH)
+ # for gprof to make coverage reports - Jenkins
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
+endif()
+
+if(CGAL_FOUND)
+ if (NOT CGAL_VERSION VERSION_LESS 4.8.0)
+ if (EIGEN3_FOUND)
+ message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
+ include( ${EIGEN3_USE_FILE} )
+ include_directories (BEFORE "../../include")
+
+ add_executable( Tangential_complex_test_TC test_tangential_complex.cpp )
+ target_link_libraries(Tangential_complex_test_TC ${CGAL_LIBRARY} ${Boost_DATE_TIME_LIBRARY} ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Tangential_complex_test_TC ${TBB_LIBRARIES})
+ endif()
+ add_test(Tangential_complex_test_TC ${CMAKE_CURRENT_BINARY_DIR}/Tangential_complex_test_TC
+ # XML format for Jenkins xUnit plugin
+ --log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/Tangential_complex_UT.xml --log_level=test_suite --report_level=no)
+
+ endif()
+ endif ()
+endif() \ No newline at end of file