summaryrefslogtreecommitdiff
path: root/src/Toplex_map/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2019-12-12 17:17:18 +0100
committerGitHub <noreply@github.com>2019-12-12 17:17:18 +0100
commit2607200636eb01e4df5735ec311d3a69db5ed589 (patch)
tree0607f688a06e133a75addfd5d02d6bd5941339e3 /src/Toplex_map/test/CMakeLists.txt
parent5a5a534b840216719fb3f9cb819d1306ca7ed196 (diff)
parentb884a620824a9d707cec82c9dddf7ab236263b95 (diff)
Merge pull request #174 from VincentRouvreau/ctest_shall_output_failures
Fix #168 - Ctest shall output failures
Diffstat (limited to 'src/Toplex_map/test/CMakeLists.txt')
-rw-r--r--src/Toplex_map/test/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/Toplex_map/test/CMakeLists.txt b/src/Toplex_map/test/CMakeLists.txt
index 59517db5..2997584d 100644
--- a/src/Toplex_map/test/CMakeLists.txt
+++ b/src/Toplex_map/test/CMakeLists.txt
@@ -1,11 +1,9 @@
project(Toplex_map_tests)
-include(GUDHI_test_coverage)
+include(GUDHI_boost_test)
add_executable( Toplex_map_unit_test toplex_map_unit_test.cpp )
-target_link_libraries(Toplex_map_unit_test ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
-gudhi_add_coverage_test(Toplex_map_unit_test)
+gudhi_add_boost_test(Toplex_map_unit_test)
add_executable( Lazy_toplex_map_unit_test lazy_toplex_map_unit_test.cpp )
-target_link_libraries(Lazy_toplex_map_unit_test ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
-gudhi_add_coverage_test(Lazy_toplex_map_unit_test)
+gudhi_add_boost_test(Lazy_toplex_map_unit_test)