summaryrefslogtreecommitdiff
path: root/src/Witness_complex
diff options
context:
space:
mode:
authorfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-25 11:19:00 +0000
committerfgodi <fgodi@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2017-10-25 11:19:00 +0000
commit23e265d8c48d921a51eb0265afa6d8af27b27559 (patch)
treef008c1dc24209204ede4b69386f6bf56513a72c2 /src/Witness_complex
parent8fd07bda067d82fd0d345c3bde0dce7de18a6722 (diff)
include limits in toplex_map
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/toplex_map@2804 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: a42cc7c557c193c57e3696eb0b877f6196841aaf
Diffstat (limited to 'src/Witness_complex')
-rw-r--r--src/Witness_complex/example/CMakeLists.txt2
-rw-r--r--src/Witness_complex/example/example_strong_witness_complex_off.cpp4
2 files changed, 4 insertions, 2 deletions
diff --git a/src/Witness_complex/example/CMakeLists.txt b/src/Witness_complex/example/CMakeLists.txt
index cbc53902..0f709409 100644
--- a/src/Witness_complex/example/CMakeLists.txt
+++ b/src/Witness_complex/example/CMakeLists.txt
@@ -14,6 +14,7 @@ install(TARGETS Witness_complex_example_nearest_landmark_table DESTINATION bin)
if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)
add_executable( Witness_complex_example_off example_witness_complex_off.cpp )
add_executable( Witness_complex_example_strong_off example_strong_witness_complex_off.cpp )
+add_executable( Witness_complex_example_strong_fvecs example_strong_witness_complex_fvecs.cpp )
add_executable ( Witness_complex_example_sphere example_witness_complex_sphere.cpp )
add_executable ( Witness_complex_example_witness_persistence example_witness_complex_persistence.cpp )
@@ -44,6 +45,7 @@ if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.6.0)
install(TARGETS Witness_complex_example_off DESTINATION bin)
install(TARGETS Witness_complex_example_strong_off DESTINATION bin)
+ install(TARGETS Witness_complex_example_strong_fvecs DESTINATION bin)
install(TARGETS Witness_complex_example_sphere DESTINATION bin)
install(TARGETS Witness_complex_example_witness_persistence DESTINATION bin)
install(TARGETS Witness_complex_example_strong_witness_persistence DESTINATION bin)
diff --git a/src/Witness_complex/example/example_strong_witness_complex_off.cpp b/src/Witness_complex/example/example_strong_witness_complex_off.cpp
index 4a232481..6292e248 100644
--- a/src/Witness_complex/example/example_strong_witness_complex_off.cpp
+++ b/src/Witness_complex/example/example_strong_witness_complex_off.cpp
@@ -50,8 +50,8 @@ int main(int argc, char * const argv[]) {
int nbL = atoi(argv[2]), lim_dim = atoi(argv[4]);
double alpha2 = atof(argv[3]);
clock_t start, end;
- //Gudhi::Simplex_tree<> simplex_tree;
- Gudhi::Fake_simplex_tree simplex_tree;
+ Gudhi::Simplex_tree<> simplex_tree;
+ //Gudhi::Fake_simplex_tree simplex_tree;
// Read the point file
Point_vector point_vector, landmarks;