summaryrefslogtreecommitdiff
path: root/src/cmake/modules/GUDHI_user_version_target.cmake
diff options
context:
space:
mode:
authorVincent Rouvreau <10407034+VincentRouvreau@users.noreply.github.com>2020-04-25 07:43:36 +0200
committerGitHub <noreply@github.com>2020-04-25 07:43:36 +0200
commit0fb22e4c499b665ad505e5d9d2c325f7561f69c4 (patch)
treed6fc030994f4987d6abd29bef87d9a192922a4fe /src/cmake/modules/GUDHI_user_version_target.cmake
parentd895af4897cb4169486197dec925a8a16d4de9cf (diff)
parent66337063d2ee3770275268c264548e99db3ec7f0 (diff)
Merge pull request #292 from VincentRouvreau/one_biblio_for_all_sphinx
Fix bibliography for sphinx
Diffstat (limited to 'src/cmake/modules/GUDHI_user_version_target.cmake')
-rw-r--r--src/cmake/modules/GUDHI_user_version_target.cmake6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/cmake/modules/GUDHI_user_version_target.cmake b/src/cmake/modules/GUDHI_user_version_target.cmake
index 257d1939..9cf648e3 100644
--- a/src/cmake/modules/GUDHI_user_version_target.cmake
+++ b/src/cmake/modules/GUDHI_user_version_target.cmake
@@ -26,8 +26,12 @@ add_custom_command(TARGET user_version PRE_BUILD COMMAND ${CMAKE_COMMAND} -E
# Generate bib files for Doxygen - cf. root CMakeLists.txt for explanation
string(TIMESTAMP GUDHI_VERSION_YEAR "%Y")
configure_file(${CMAKE_SOURCE_DIR}/biblio/how_to_cite_gudhi.bib.in "${CMAKE_CURRENT_BINARY_DIR}/biblio/how_to_cite_gudhi.bib" @ONLY)
-file(COPY "${CMAKE_SOURCE_DIR}/biblio/how_to_cite_cgal.bib" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/biblio/")
file(COPY "${CMAKE_SOURCE_DIR}/biblio/bibliography.bib" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/biblio/")
+
+# append cgal citation inside bibliography - sphinx cannot deal with more than one bib file
+file(READ "${CMAKE_SOURCE_DIR}/biblio/how_to_cite_cgal.bib" CGAL_CITATION_CONTENT)
+file(APPEND "${CMAKE_CURRENT_BINARY_DIR}/biblio/bibliography.bib" "${CGAL_CITATION_CONTENT}")
+
# Copy biblio directory for user version
add_custom_command(TARGET user_version PRE_BUILD COMMAND ${CMAKE_COMMAND} -E
copy_directory ${CMAKE_CURRENT_BINARY_DIR}/biblio ${GUDHI_USER_VERSION_DIR}/biblio)