summaryrefslogtreecommitdiff
path: root/src/common/test
diff options
context:
space:
mode:
authorvrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-10-13 12:49:58 +0000
committervrouvrea <vrouvrea@636b058d-ea47-450e-bf9e-a15bfbe3eedb>2015-10-13 12:49:58 +0000
commitf23994c41f3d943fae980693d9cd832820fcee42 (patch)
tree8555902995899046ae523e317d44e8946a85c1a8 /src/common/test
parentc14909eae41883308428095758360de3a7202a0d (diff)
parent6fd64ffb734f09eeb40aade1efa2e03666eb65b9 (diff)
Backmerge from trunk
git-svn-id: svn+ssh://scm.gforge.inria.fr/svnroot/gudhi/branches/alphashapes@853 636b058d-ea47-450e-bf9e-a15bfbe3eedb Former-commit-id: 3f1b56bf4986df7bb2938ea2fff944eb9bf9b653
Diffstat (limited to 'src/common/test')
-rw-r--r--src/common/test/CMakeLists.txt5
-rw-r--r--src/common/test/dtoffrw_unit_test.cpp4
2 files changed, 7 insertions, 2 deletions
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index 1b4dd6e0..a395338e 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -22,6 +22,11 @@ if(CGAL_FOUND)
add_executable ( dtoffrw_UT dtoffrw_unit_test.cpp )
target_link_libraries(dtoffrw_UT ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+ # Do not forget to copy test files in current binary dir
+ file(COPY "dtoffrw_alphashapedoc_result.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Do not forget to copy test files in current binary dir
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/alphacomplexdoc.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
# Unitary tests
add_test(dtoffrw_UT ${CMAKE_CURRENT_BINARY_DIR}/dtoffrw_UT
# XML format for Jenkins xUnit plugin
diff --git a/src/common/test/dtoffrw_unit_test.cpp b/src/common/test/dtoffrw_unit_test.cpp
index ada218ac..cc6f283e 100644
--- a/src/common/test/dtoffrw_unit_test.cpp
+++ b/src/common/test/dtoffrw_unit_test.cpp
@@ -41,7 +41,7 @@ typedef CGAL::Delaunay_triangulation<K> T;
BOOST_AUTO_TEST_CASE( Delaunay_triangulation_doc_test )
{
// Read the OFF file (input file name given as parameter) and triangulates points
- Gudhi::Delaunay_triangulation_off_reader<T> off_reader("../../../data/points/alphacomplexdoc.off");
+ Gudhi::Delaunay_triangulation_off_reader<T> off_reader("alphacomplexdoc.off");
// Check the read operation was correct
BOOST_CHECK(off_reader.is_valid());
@@ -73,7 +73,7 @@ BOOST_AUTO_TEST_CASE( Delaunay_triangulation_unexisting_file_read_test )
BOOST_AUTO_TEST_CASE( Delaunay_triangulation_unexisting_file_write_test )
{
// Read the OFF file (input file name given as parameter) and triangulates points
- Gudhi::Delaunay_triangulation_off_reader<T> off_reader("../../../data/points/alphacomplexdoc.off");
+ Gudhi::Delaunay_triangulation_off_reader<T> off_reader("alphacomplexdoc.off");
// Retrieve the triangulation
T* triangulation = off_reader.get_complex();