summaryrefslogtreecommitdiff
path: root/src/python/CMakeLists.txt
diff options
context:
space:
mode:
authorHind-M <hind.montassif@gmail.com>2021-09-27 15:19:25 +0200
committerHind-M <hind.montassif@gmail.com>2021-09-27 15:19:25 +0200
commit8749199e00c0ed1c32b8e0198a65797de3ad192a (patch)
tree87d40db04e7bfb363913aa7fd13c3bfed11b0a85 /src/python/CMakeLists.txt
parent82524c5b0a6ab02b020574b2200a8721f3ed424c (diff)
Add option in cmake to enable or not the inclusion of datasets fetching test (disabled by default)
Diffstat (limited to 'src/python/CMakeLists.txt')
-rw-r--r--src/python/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 6f117588..6c8dfe32 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
@@ -543,7 +543,9 @@ if(PYTHONINTERP_FOUND)
endif()
# Fetch remote datasets
- add_gudhi_py_test(test_remote_datasets)
+ if(WITH_NETWORK)
+ add_gudhi_py_test(test_remote_datasets)
+ endif()
# Set missing or not modules
set(GUDHI_MODULES ${GUDHI_MODULES} "python" CACHE INTERNAL "GUDHI_MODULES")